-   Linux - Kernel (
-   -   tmpfs not being used? (

tmerriam 05-13-2012 03:14 PM

tmpfs not being used?
One of my partitons is running out of space, I can't resize it right now, so I'm trying to mount one of the temp file directories on tmpfs.


/var/tmp/kdecache-user tmpfs tmpfs nodev,nosuid,size=512M 0 0

Reboot, and...


/var/tmp/kdecache-user on /tmpfs type tmpfs (rw,nodev,nosuid,size=512M)


df -h
Filesystem            Size Used Avail Mounted on
/var/tmp/kdecache-user 512M    0  512M /tmpfs

ls shows that there are files in /var/tmp/kdecache-user, so why isn't this working?

TobiSGD 05-13-2012 03:19 PM

To mount a directory to RAM should work like you want, but you have mixed up the order of the statements in your fstab, it should be

tmpfs /var/tmp/kdecache-user tmpfs nodev,nosuid,size=512M 0 0

tmerriam 05-13-2012 06:33 PM


Ok, I fixed that part but it still doesn't work. I added the uid, gid, and mode options to the fstab entry, and set the permissions on the mount point, but KDE is just making another folder instead! I tried putting the mount point in /mnt and linking to it from /var/tmp, but I have the same issue. Any ideas as to how to trick KDE into using the tmpfs?

tmerriam 05-15-2012 07:51 PM

I couldn't get just /var/tmp/kdecache into tmpfs, so I mounted on /var/tmp instead. Took off the uid, gid, and mode option from the mount entry, too.

All times are GMT -5. The time now is 09:52 PM.