-   Linux - Kernel (
-   -   switching to mkinitcpio causing kernel panic due to raid' (

Fredde87 12-03-2006 11:16 AM

switching to mkinitcpio causing kernel panic due to raid'

I have just switched from mkinitrd to mkinitcpio as support for it has been dropped in archlinux. I tried it a while back ago and had problems but thought it might just be a version bug so I have waited 5 months and decided today to switch to it as I was having other problems with the server as well.

Anyway, what happens is the server boots and receive a kernel panic as the raid array isnt being setup as it should.

It crashes after Attempting to create root device /dev/md0 in the "Loading root filesystem module... -e" part. The first error message says "ERROR: Failed to parse block device name for /dev/md0
It then says "ERROR: root fs cannot be detected. Try using the rootfstype kernel parameter". I have ofcourse tried this but it doesnt change anything.

It will then enter the Running Hook [raid] phase where it will start to configure and load md0 and then spit out an error sayíng "opeen failed - cannot start array /dev/md0"

It then goes to kinit but since it cant find the kernel it gives me a kernel panic.

Any suggestions on what to try?


syg00 12-04-2006 08:42 PM

Thought I saw something in the wiki about raid hook being available but not enabled by default when I looked a while back. I don't use raid, so I skimmed it.
Check out the (Arch) wiki/forums.

Fredde87 12-05-2006 03:29 AM

What do you mean by enabled? I have added it to raid to hooks in mkinitcpio.conf and added the md=0,/dev/hd..... line to menu.lst

All times are GMT -5. The time now is 06:40 PM.