-   Linux - Kernel (
-   -   /sbin/init: Kernel panic - not syncing: Attempted to kill init! (

jalejo08 05-03-2009 01:28 PM

/sbin/init: Kernel panic - not syncing: Attempted to kill init!
I was working normally in my ubuntu 8.10 x64, when I open console and write ls, say a message: Command not found!!
I scare and rebbot immediatly, but now i get this error when system start:


booting up from (hd0,2) ext3
Starting up...
Loading, please wait...
usb1-1: device not accepting address 2, error -62
hub 1-0:1.0: unable to enumerato USB device on port 1
19+0 records in
19+0 records out
kinit: nate_to_dev_t(/dev/disk/by-uuid/......)=dev(8,4)
kinit: trying to resume from /dev/disk/by-uuid/......
kinit: no resume image, doing normal boot...
/sbin/init: no such file or directory
Kernel panic - not syncing: Attempted to kill init!

what is this error?? I don't know what happend.

rjlee 05-03-2009 04:06 PM

The fact that ls wasn't found means that the /bin/ls file doesn't exist.
The error you have on boot is that /sbin/init also doesn't exist.

You probably have a corrupt filesystem, which could be caused by a damaged hard disk (assuming that no-one's actually deleted the files). It's a shame that you rebooted straight away since it would have been nice to see the log entries (/var/log/messages and the dmesg command) to see if there were any reported errors.

There are some things you can try here, for example, you could use init=/bin/bash to be dropped into a shell when you log in, bypassing /sbin/init completely. But that won't work if /bin/bash is broken.

The best thing to do is to download a live CD, boot from that, and then run fsck to do a check of the disk. System Rescue CD is a live CD tailored towards system recovery; I've never used it but there's quite a bit of documentation on their website:

For example:


fsck /dev/hda2
You will need to run this for each partition on your hard disk (you can get the device names for the partitions from the gparted program).

Hope that helps,

—Robert J Lee

sundialsvcs 05-04-2009 08:57 PM

I agree... and run smartdrv too if you have it. I think that you'll find that your hard-drive just pooped. :eek:

jalejo08 05-06-2009 10:12 PM

But Is strange. Because I have windows in other partition and it works nice.
I try boot from liveCD and I can read all partitions, and I already get a backup of important data.

I has download System Rescue CD, I will to try whit this...

smkururu 05-23-2009 11:47 AM

Why do you need System Rescue CD? I think Reinstalling your linux is better.

titetanium 05-25-2009 12:19 AM

Reinstalling might be better only if he/she can save his/her important data first somewhere. Preferably /home and some /etc config files that were customized to work with his/her hardware. Otherwise, he/she might feel that's a lot of work to figure out what he/she did to get the few components working the way he/she wants if the drive was reformatted and reinstalled. I'm doing the same thing and there are differences between the original install and the reinstall since some config files were changed in the interim.

jalejo08 05-25-2009 03:40 PM

I did not want to reinstall my linux because I has many configurations ready, although using a live cd, I could access to all info on hard disk and backup it.

:mad: I gave up and reinstall my linux.

pedroghilardi 07-02-2009 01:16 PM

Same problem!
I have ubuntu 9.04 and i have the same problem! I was compiling some C++ files on terminal when i tried to execute ls and i got an ERROR message: bin/ls not found!

After that i tried to open nautilus without success, and Computer without success... So I restarted my PC and got the error SBIN/INIT: NO SUCH FILE OR DIRECTORY.

After that, I formatted my system three times and all the times this error occurred again. I have windows in another partition working fine...

Why this error is happening?

All times are GMT -5. The time now is 01:04 PM.