LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
Search this Thread
Old 09-23-2009, 03:49 AM   #1
bojanap
LQ Newbie
 
Registered: Sep 2009
Posts: 2

Rep: Reputation: 0
Running kernel.org "mainline" Linux on Xen: FAILED to find root device


Hi,

I compiled kernel.org 2.6.25.14 kernel on Fedora 10 with all necessary Xen options enabled. After successful process of compilation command file gave me this result:

file /boot/*

/boot/vmlinuz-2.6.27.5-117.fc10.i686.PAE: Linux kernel x86 boot executable RO-rootFS, root_dev 0x902, swap_dev 0x2, Normal VGA
/boot/vmlinuz-2.6.25.14: Linux kernel x86 boot executable RO-rootFS, swap_dev 0x2, Normal VGA

We can see that in comparison to original Fedora 10 kernel, root_dev 0x902 is missing from the vmlinuz. I checked all other relevant parameters and everything else seems fine.

Does anybody know how to set up properly root device and what is the reason for failure?
I tried with rdev command which gives:
rdev /boot/vmlinuz-2.6.25.14
Root device 0xca01

so, I'm wondering why this output is not included in the file command result?
 
Old 09-17-2010, 11:42 PM   #2
xeleema
Member
 
Registered: Aug 2005
Location: D.i.t.h.o, Texas
Distribution: Slackware 13.x, rhel3/5, Solaris 8-10(sparc), HP-UX 11.x (pa-risc)
Posts: 987
Blog Entries: 4

Rep: Reputation: 248Reputation: 248Reputation: 248
Greetingz!
Sounds like you might need an initrd setup for your new kernel.
Have you given mkinitrd a shot? (Check the man page!)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu Custom kernel - kp: cannot open root device "sda1" Thaidog Linux - Software 5 01-08-2009 04:34 PM
"dpkg -i ~oss-linux-4.0-1016_i386.deb"="Relinking the OSS kernel modules failed" bezdomny Linux - Software 2 07-26-2008 04:06 PM
New kernel - VFS: Cannot open root device "301" or unknown block(3,1) j0y Debian 2 04-30-2005 09:14 PM
Kernel Panic:VFS: Cannot open root device "hda3" or 00:10 shivendnrab Linux - General 1 07-01-2004 03:08 AM
"Cannot find root device" this is a bad error right? steventux Linux - General 1 02-23-2003 02:42 AM


All times are GMT -5. The time now is 10:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration