Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Linux - Kernel This forum is for all discussion relating to the Linux kernel.


  Search this Thread
Old 01-20-2012, 12:13 PM   #1
LQ Newbie
Registered: Jan 2012
Posts: 2

Rep: Reputation: Disabled
RedHat Linux loads root as read only filesystem

Hello All,
I had a problem with my RedHat Linux machine. I am running it on Virtual Box. Initially the system was not booting at all and directly entered the Grub command line.

I booted it from Linux CD and entered the Linux rescue mode and all filesystem were mounted fine there. I then looked at the grub.config it was empty. I added to it contains from another grub.conf made the necessary changes and rebooted the system.

Now the system boots but at the end I get the following logs

Waiting for driver initialization.
Scanning and configuring dmraid supported devices
Trying to resume from LABEL=SWAP=sda7
No suspended signature on swap, not resuming.
Creating root device.
Mounting root filesystem.
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Setting up other filesystems.
Setting up new root fs
no fstab.sys, mounting internal defaults
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys

and then the system shows root login with no hostname.

The root file system is in read only mode and no other file systems are mounted. I can mount the other file systems using mount command and it mounts properly. No devices are initialized like the ethernet network and others.

I have no idea what to do Any suggestions

Old 01-21-2012, 03:49 AM   #2
Registered: Feb 2009
Posts: 347

Rep: Reputation: 72
You will have to add the entries in fstab for what ever file systems you want to mount, your log says there is no fstab so it will not mount any thing by itself.
May be if you show your grub.conf file it might be easier to help
Old 01-23-2012, 09:01 AM   #3
LQ Newbie
Registered: Jan 2012
Posts: 2

Original Poster
Rep: Reputation: Disabled
I have the fstab file and it contains the following

LABEL=/ / ext3 defaults 1 1
LABEL=/DB0 /DB0 ext3 defaults 1 2
LABEL=/wd00 /wd00 ext3 defaults 1 2
LABEL=/export/home /export/home ext3 defaults 1 2
LABEL=/V0 /V0 ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
LABEL=SWAP-sda7 swap swap defaults 0 0

This is my grub.conf file

# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,0)
# kernel /boot/vmlinuz-version ro root=/dev/sda1
# initrd /boot/initrd-version.img
title Red Hat Enterprise Linux Server (2.6.18-194.el5)
root (hd0,0)
kernel /boot/vmlinuz-2.6.18-194.el5 ro root=LABEL=/
initrd /boot/initrd-2.6.18-194.img

I have made a new initrd file using the mkinitrd command that too did not solved the problem.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] ext2fs_mkdir: Attempt to read block from filesystem resulted in short read while creating root dir TheIndependentAquarius Linux - Newbie 10 12-29-2011 08:11 AM
[SOLVED] how can i remount root filesystem as read/write after modify readonly-root file jcwkyl Linux - Newbie 3 12-21-2010 11:40 PM
root filesystem keeps going read only dappa_don Linux - Server 5 05-26-2009 09:47 AM
How can I have: Root has Read-Write, user has read only for the boot filesystem? xmrkite Linux - Software 6 10-16-2008 05:31 AM
recover root filesystem redhat linux mohsinjq Linux - Newbie 4 11-10-2004 10:30 AM > Forums > Linux Forums > Linux - Software > Linux - Kernel

All times are GMT -5. The time now is 02:22 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration