-   Linux - Kernel (
-   -   Problem installing module in Fedora Core 2 (2.6 kernel vs 2.4 problem?) (

Arodef 07-19-2004 11:36 PM

Problem installing module in Fedora Core 2 (2.6 kernel vs 2.4 problem?)
I need to install a driver provided by a custom hardware manufacterer for a card I am testing. The driver is tested for Redhat 9 and Redhat Enterprise. only. However I have also gotten it to work under Fedora Core 1 (2.4 kernel). I just tried to install this driver on Fedora Core 2 and got the following error:

mkdir -p /lib/modules/2.6.5-1.358smp/kernel/drivers/misc
cp LINUX.2.6.5-1.358smp/windrvr6.ko /lib/modules/2.6.5-1.358smp/kernel/drivers/misc
./wdreg windrvr6
FATAL: Error inserting windrvr6 (/lib/modules/2.6.5-1.358smp/kernel/drivers/misc/windrvr6.ko): Invalid module format
make: *** [install] Error 1

A successful install on Fedora Core 1 looks like this.

mkdir -p /lib/modules/misc
cp LINUX.2.4.22-1.2197.nptlsmp/windrvr6.o /lib/modules/misc
./wdreg LINUX.2.4.22-1.2197.nptlsmp/windrvr6.o
Warning: loading /lib/modules/misc/windrvr6.o will taint the kernel: non-GPL license - Proprietary
See for information about tainted modules
Module windrvr6 loaded, with warnings

I believe this is an issue with the 2.6 kernel? Is it a security feature (notice the taint the kernel message from FC1 install) so they don't allow these types of installs anymore? Are there any workarounnds I can do on my part or do I have to rely on the driver maker? They are only supporting Redhat so I can't rely on them to make something compatible with FC. The driver itself comes packaged in an rpm BTW. Thanks.

WMD 07-20-2004 01:18 PM

Definately a 2.6 error. That's a binary-only module, so it can't be recompiled to work with 2.6 (unless the company does it). You can ask them to make a 2.6 kernel version (should only require a recompile).

Arodef 07-20-2004 05:09 PM

Is it possible for them to release the driver in a tar format that I can compile myself? I believe before rpm's that's how most installations worked? Can they release such a driver while still protecting their source code?

Having dealt with their tech support before, I don't expect them to recompile a driver just for me but I'll give it a shot.

BTW, from a hardware company point of view, is it very difficult to make a driver that is compatible with all the different linux distributions/kernels?

debsys07 11-30-2007 02:55 PM

Problem resolved?
I'm having similar problems running some Xilinx s/w (V6.2i) under Debian 'etch'. Windrvr6 module is not there & current version (9.x) is probably incompatible. Did you ever resolve this?

Thanks, Ron

All times are GMT -5. The time now is 10:26 PM.