-   Linux - Kernel (
-   -   Newbie trying to install Slackware 10.1 on flash drive (

Quasix 04-30-2006 10:43 AM

Newbie trying to install Slackware 10.1 on flash drive
Hi everyone, I have been trying for quite a while to install Slackware on a 1GB flash drive. (I have referenced similar posts listed here). I keep running into the same problem:
VFS: Cannot open root device "802" or 08:02. - Kernel panic: VFS: Unable to mount root fs on 08:02. I am aware that 08:02 refers to me trying to mount /dev/sda2, but I have tried many other "sd" possibilities.

These are the things I've tried:
I started out trying to boot with zipslack, using DOS for the initial boot on the flash drive and booting the kernel using the loadlin command and got the same error. I tried booting into dos with a floppy disk, navigating to the flash drive, and using loadlin. I tried installing slackware (I left out all xwindows and some other functionality so it would fit) directly onto the flash drive using the CDs (version 10.1) - it installed like a charm - I partitioned the flash drive with 64M linux swap, and the rest linux, and made the linux partition bootable. I tried starting with LILO on the superblock and on a floppy - both times, LILO comes up just fine, and I can see the linux partition, but when I try to boot the kernel, it gives me the same error. I don't understand how DOS, LILO, fdisk, and the installation CD's have no trouble finding the flash drive, but the kernel just can't seem to get it - I can even boot to dos or lilo from the flash drive, but the kernel won't boot. I have also used several of the kernels available on-line - all of which say they support both IDE and SCSI. I even compiled a kernel, giving it as much SCSI functionality as I could (not that I know what I'm doing), and that didn't work. For every try, I attempted booting from sda1, sda2, sda3, sda4, sdb1, ..... and so on. Same thing. I have tried booting using a P4 Dell Laptop, a pentium 3 box, and an athlon 1700 box - all have capabilities to boot from USB drives, all with the same results. At the Kernel scrolled up panic message, I've to see if the kernel detected anything other than the hard-drives and CD-drives, but I can never find anything.

I am simply at a point where I can't think of anything else to try. I'm sure many people have done this, but it's beyond me. Does anyone have any suggestions on what more I could do?

Thanks for your time!

debasish_5849 05-01-2006 01:21 PM

The problem with the kernel is that it has to find some of its own modules before it can load fully. Your kernel needs probably a rebuild with the usb and flash drivers statically linked with the kernel, i.e. they must remain within the kernel rather than built as modules. Say Y instead of M for those drivers when configuring the kernel before compiling it.

Quasix 05-01-2006 10:15 PM

Thanks for the reply! There were several items that were set up as modules: I made sure things like "Support for USB" and "USB Mass Storage Support" were on "y" instead of "M". Unfortunately, I'm getting no difference in the boot though. As a matter of fact, there is such little difference, I wasn't even sure I did anything - to test it, I simply removed the kernel file completely from my flash drive and tried booting to see what error messages I would get. It turns out that everything was the same as before! It did the same thing... looked for floppy controllers, PCI stuff, detected hda and hdc for the harddrive and cdrom... then gave me the same error! Of course, I'm wondering now if I know even less than I thought I did - is lilo doing all this stuff? Where is it getting the instructions to check for this hardware if I removed the kernel file? My lilo.conf is pretty straight forward:
boot = /dev/sda2
message = /boot/boot_message.txt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/sda2
label = Linux
Is there some other instruction set that checks for hardware, or could I be way off and be trying to boot from some file I have no idea about?

All times are GMT -5. The time now is 02:51 PM.