LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices


Reply
  Search this Thread
Old 03-15-2018, 10:01 AM   #16
konstantin1
LQ Newbie
 
Registered: Feb 2018
Posts: 15

Original Poster
Rep: Reputation: Disabled

The question is now, what magic kernel parameter(s) should I pass to make kernel starting thread-safe (or HT safe) on my PC, to avoid that possible race condition?
 
Old 03-17-2018, 02:00 AM   #17
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 9,720
Blog Entries: 7

Rep: Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401
i'm not sure if a community-maintained fork of a rolling distro is the best solution for this dinosaur.
i would go with a different distro altogether.
maybe debian oldstable (jessie)?
 
Old 03-17-2018, 11:42 AM   #18
konstantin1
LQ Newbie
 
Registered: Feb 2018
Posts: 15

Original Poster
Rep: Reputation: Disabled
I don't want to install a completely new linux distribution, because then I would have even more problems, I think. Right now I have only this particular problem to solve.

Now it seems, by using the mentioned kernel parameters and booting to the -lts kernel of Arch Linux 32, it works, and kernel loads fine even if HT is enabled.

Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset debug ignore_loglevel earlyprintk=vga,keep log_buf_len=16M memory_corruption_check=1 bootmem_debug memtest acpi=ht ht=on"
htop shows now 2 virtual processor cores:

https://i.imgur.com/ZJq6KiL.png

Last edited by konstantin1; 03-17-2018 at 11:45 AM.
 
Old 03-21-2018, 11:18 PM   #19
konstantin1
LQ Newbie
 
Registered: Feb 2018
Posts: 15

Original Poster
Rep: Reputation: Disabled
Problem still not solved, as I choose whatever kernel, I have to restart my machine 3x-4x to load the kernel properly.
Appropriate kernel parameter still wanted.
 
Old 03-23-2018, 02:18 PM   #20
konstantin1
LQ Newbie
 
Registered: Feb 2018
Posts: 15

Original Poster
Rep: Reputation: Disabled
I have tried
Code:
maxcpus=1
Kernel parameter, which disables HT. I could enable it later, when system has been successfully started by running
Code:
echo 1 > /sys/devices/system/cpu/cpu1/online
But this still doesn't work.
 
Old 03-24-2018, 02:45 AM   #21
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 9,720
Blog Entries: 7

Rep: Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401
i have given a few hints that you chose to either ignore or explain away.
plese re-read and re-consider posts #7, #9 and #11.

you are aware that archlinux32 is a very young project? i'm not sure at all how stable it is and i strongly question the usefulness of trying to use it (or archlinux in general) on a dinosaur, because of archlinux' rolling nature.

add to that the possibly deeper problem (see #11, not linux related) and the sheer age of the machine (could simply be failing hardware) - i really don't see why you are making life even harder for yourself by using a beta rolling very new project.

try antiX or slitaz.
 
Old 03-27-2018, 10:30 PM   #22
konstantin1
LQ Newbie
 
Registered: Feb 2018
Posts: 15

Original Poster
Rep: Reputation: Disabled
I am using this distro, because everything works out of the box on my PC, except the kernel starting. After I manage to start the kernel with a few restart, everything works perfectly.
 
Old 03-28-2018, 12:33 PM   #23
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 9,720
Blog Entries: 7

Rep: Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401
then please mark your thread solved.
 
Old 03-28-2018, 06:18 PM   #24
konstantin1
LQ Newbie
 
Registered: Feb 2018
Posts: 15

Original Poster
Rep: Reputation: Disabled
But the kernel still doesn't start properly, I always have to restart the PC 3-4 times till the kernel loads properly. I would need some relevant kernel parameter, which fixes this small but annoying issue.
 
Old 03-29-2018, 01:44 AM   #25
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 9,720
Blog Entries: 7

Rep: Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401
i assume your enquiries on archlinux32 forums went unanswered?
 
Old 04-06-2018, 03:27 PM   #26
konstantin1
LQ Newbie
 
Registered: Feb 2018
Posts: 15

Original Poster
Rep: Reputation: Disabled
yes, that forum has only a low member count, after 200 views of my question there was no answer at all. Same with the original Arch Linux forum, no relevant answers.

Last edited by konstantin1; 04-06-2018 at 03:36 PM.
 
Old 04-06-2018, 04:11 PM   #27
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, Manjaro
Posts: 8,844
Blog Entries: 14

Rep: Reputation: 1080Reputation: 1080Reputation: 1080Reputation: 1080Reputation: 1080Reputation: 1080Reputation: 1080Reputation: 1080
Quote:
Originally Posted by konstantin1 View Post
But the kernel still doesn't start properly, I always have to restart the PC 3-4 times till the kernel loads properly. I would need some relevant kernel parameter, which fixes this small but annoying issue.
If the kernel is not starting properly it may be that modules are missing.
-::-Sometimes when nothing else works recompiling the kernel helps. -::-

https://www.linuxquestions.org/quest...kernel-587787/

https://www.archlinux.org/news/phasi...-i686-support/

Try debugging:
https://www.kernel.org/doc/html/v4.1...arameters.html

Run Memtest over night to make sure the RAM isn't bad:-

Do you have the same booting issue with other distributions?

Last edited by Ztcoracat; 04-06-2018 at 04:20 PM.
 
Old 04-06-2018, 04:24 PM   #28
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, Manjaro
Posts: 8,844
Blog Entries: 14

Rep: Reputation: 1080Reputation: 1080Reputation: 1080Reputation: 1080Reputation: 1080Reputation: 1080Reputation: 1080Reputation: 1080
Looking here:
https://itsfoss.com/arch-linux-32-bit/

It's probably best to try another distro:-
 
Old 06-04-2018, 12:06 AM   #29
X-LFS-2010
Member
 
Registered: Apr 2016
Posts: 382

Rep: Reputation: Disabled
try getting a different kernel package from your debian-ish distro. there has to be more than one choice. for debian ubuntu et all: they probably give you many choices

(you could try making your own but it could cause problems with ubuntu since the userland depends on many kernel options being set a particular way)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Mysterious 8 second delay in boot after grub crxssi Fedora 19 09-18-2017 05:41 PM
OS will not boot after good installation. Freezes at startup with error, maybe LILO? ShockProductions Slackware 4 08-06-2007 10:32 AM
Startx freezes system completely, mysterious white dots Dymitry Slackware 5 02-19-2007 04:41 PM
Mysterious F: partition on dual boot system bigoli Linux - Software 2 01-21-2005 12:15 PM
fedora core 2 (FC2) freezes while running. Cannot boot into KDE it freezes mraswan Fedora 0 05-25-2004 07:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel

All times are GMT -5. The time now is 06:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration