Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Linux - Kernel This forum is for all discussion relating to the Linux kernel.


  Search this Thread
Old 11-15-2009, 10:48 AM   #1
LQ Newbie
Registered: Nov 2006
Posts: 8

Rep: Reputation: Disabled
Unhappy Keyboard delay in ttys (from 2.6.28-16-generic to on Ubuntu 9.04 Jaunty)

Greetings to everyone.

I have recently started a Linux kernel hacking course at university. So I enjoyed taking a closer look at kernels, and decided I wanted to have the latest kernel on my Ubuntu.

So I downloaded from I configured it by copying the default 2.6.28-16-generic config that comes in the Ubuntu kernel package, doing `make oldconfig` and answering new question ALL with the defaults.

Compiled it and installed it -- it works like a charm. Everything is as before, if not better. However.

I seem to have a strange delay problem with terminals.

If I open a terminal and start writing, my keyboard input hangs for exactly for 1/4 of second every two seconds, and then everything I typed in that 1/4 second shows up all at once.

As a clarifying example: if I keep the `T` key pressed, it repeats as normal, but every 2 seconds it seems to stop for a 1/4 second, after which all the `T`s which would have been printed in that time are printed all at once.

I have this problem every time I type into a terminal, be it gnome-terminal, xterm, or even the CTRL+ALT+F1 console. But this does NOT happen if I type in GUI applications. For example, if I type in Firefox or gedit, everything works ok. It's just ttys that have this problem. Also, programs writing on standard output don't hang like that - only input does. Killing X doesn't help.

Booting with the old kernel removes the problem. So this looks like a new kernel feature that my hardware doesn't like.

Anyone that successfully addressed the same problem?

Thank you very much.

Last edited by anon05; 11-15-2009 at 11:07 AM.
Old 12-31-2009, 02:28 AM   #2
Registered: Feb 2005
Posts: 75

Rep: Reputation: 16
I have this problem on Karmic with the stock kernel. Ever find a good solution?
Old 01-01-2010, 08:30 AM   #3
LQ Newbie
Registered: Nov 2006
Posts: 8

Original Poster
Rep: Reputation: Disabled
Well, actually I just gave up the idea and reinstalled the "old" stock kernel.
I guess a subsequent patch will someday fix the problem, which maybe is specific to our platform.

Meanwhile, I hope I won't miss too much.


delay, keyboard, seconds, terminal, tty, ubuntu

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Upgrade Ubuntu 9.04 (Jaunty Jackalope) to Ubuntu 9.10 (Karmic Koala) Beta LXer Syndicated Linux News 0 10-12-2009 08:50 AM
LXer: Install The Proposed Comunity Themes For Ubuntu Karmic Koala, In Ubuntu Jaunty LXer Syndicated Linux News 0 09-17-2009 03:20 AM
remove gnome-desktop ubuntu and strictly use lxde ubuntu 9.04 Jaunty Polanski Linux - Software 1 05-07-2009 02:53 PM
LXer: The Perfect Server - Ubuntu Jaunty Jackalope (Ubuntu 9.04) [ISPConfig 2] LXer Syndicated Linux News 0 04-26-2009 09:50 AM
LXer: Upgrade Ubuntu 8.10 (Intrepid) to Ubuntu 9.04 (Jaunty) Beta LXer Syndicated Linux News 0 03-30-2009 06:30 AM > Forums > Linux Forums > Linux - Software > Linux - Kernel

All times are GMT -5. The time now is 01:23 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration