-   Linux - Kernel (
-   -   kernel panic VFS Unable to mount root fs (

w3stfa11 09-19-2006 10:57 PM

kernel panic VFS Unable to mount root fs
I was trying to boot Knoppix5.0 onto my brothers computer to give him a test drive of Linux. However, I got this message when it booted up.


kernel panic-not syncing VFS Unable to mount root fs
I don't remember the rest of it. I did a google search and I found a bunch of posts about this, however, I'm fairly new to *nix and I found no easy way to fix this. Does anyone have any suggestions?

My brother has a VIA chipset AMD64 and has a 250gb SATA drive (which I think is the perpetrator).

Is there something simple I can do to fix this? Maybe there's another LiveCD that would work? I also tried ubuntu6.06 and that didn't work. I didn't get the same error, I just got a black screen, but I think it's the same problem. I then gave Feather linux a quick try and the 'unable to mount...' error came up again.

Help, please. :confused:

jayjwa 09-20-2006 01:23 AM

Likely the kernel you're using is lacking support for the hard-disk, the disk controller, or both. Stock kernels, like the ones that come pre-made with distros, usually enable the most popular hardware. If you have something new or exotic it's not going to have support unless you build one specifically.

The other thing is the root filesystem, which is likely ext2 and already compiled in. If you have another live linux system, download a new kernel source and compile it with the support you need. Just trying to get the thing to boot, you may want to enable almost all of the disk controllers and hard-disk options, leaving out all the extra and fancy stuff. Once you get a successful boot, you can look at the screen and see what thing you where missing, then go back and only set that one thing for you production kernel. I went thru the same thing with a PDC20246 controller. Same error message, drove me crazy.

Whatever the computer in question is currently running, look in its hardware info section and try to see exactly what's inside it, then make sure that support is in your boot kernel.

It might be some or any of these (or not ;) ):

CONFIG_BLK_DEV_VIA82CXXX (grep'ing for VIA :D )

w3stfa11 09-20-2006 07:48 PM

That doesn't seem to be quick nor easy. :( Oh well...

All times are GMT -5. The time now is 06:59 AM.