LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Kernel (https://www.linuxquestions.org/questions/linux-kernel-70/)
-   -   Kernel Panic - not syncing: Unable to mount root fs on unknown block (0,0) (https://www.linuxquestions.org/questions/linux-kernel-70/kernel-panic-not-syncing-unable-to-mount-root-fs-on-unknown-block-0-0-a-882248/)

Yongle 05-23-2011 07:53 AM

Kernel Panic - not syncing: Unable to mount root fs on unknown block (0,0)
 
Hi guys

I am totally new to Linux (been on Windows far too long!).
Hard drive on Toshiba Protege A100 died. So with new hard drive installed decided to go Linux Ubuntu route.(single boot).Did not expect major problem at first hurdle. How naive!
I can run Ubuntu from CD, but Kernel Panic... prevents boot via Hard Drive. I have read answers to similar question in your forum but cannot understand what to do. I am not yet familiar with commands etc, so the answers are all ahead of my level of skill at this time.
I did not partition the drive, and allowed install program to format the drive. All done automatically.
What can I do to fix this?

thank you

TobiSGD 05-23-2011 08:11 AM

Boot with the CD, start a terminal, launch the following commands and post the output here:
Code:

sudo fdisk -l
cat /boot/grub/grub.cfg


Yongle 05-23-2011 09:47 AM

Quote:

Originally Posted by TobiSGD (Post 4364526)
Boot with the CD, start a terminal, launch the following commands and post the output here:
Code:

sudo fdisk -l
cat /boot/grub/grub.cfg


Thank you for your reply. If I boot from the CD, and go to Terminal, the output is:

fdisk: invalid option - - '1'
and No such file or directory
Why is it not seeing the hard drive?


THIS BELOW MAY HELP
I am sure that the hard drive has taken the files (I have installed again and everything is the same).
If I go to the command line from failed boot I can see the following in the error messages:
available partitions
0000 156290904 SDA Driver SDA
0001 152501248 SDA1
0002 1 SDA2
0005 3786752 SDA5 (is this the CD drive?)

thank you

TobiSGD 05-23-2011 09:57 AM

Quote:

Originally Posted by Yongle (Post 4364612)
fdisk: invalid option - - '1'

That is because it is an lowercase L, not a 1 (one).
That there is no output of the cat command is normal, I was somewhat dumb as I wrote that.

/dev/sda is your harddisk, it contains one primary partition /dev/sda1 and one extended partition /dev/sda2. The extended partition contains one logical partition /dev/sda5.
Now we need to find out which one is your / partition, therefore we need the output of the mentioned fdisk command.

Yongle 05-23-2011 10:18 AM

Quote:

Originally Posted by TobiSGD (Post 4364624)
That is because it is an lowercase L, not a 1 (one).
That there is no output of the cat command is normal, I was somewhat dumb as I wrote that.

/dev/sda is your harddisk, it contains one primary partition /dev/sda1 and one extended partition /dev/sda2. The extended partition contains one logical partition /dev/sda5.
Now we need to find out which one is your / partition, therefore we need the output of the mentioned fdisk command.

Sorry I misread your lowercase L. Here is the output:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000d1a89

Device Boot Start End Blocks Id System
/dev/sda1 * 1 18986 152501248 83 Linux
/dev/sda2 18986 19458 3786753 5 Extended
/dev/sda5 18986 19458 3786752 82 Linux swap / Solaris

Let us try again.

TobiSGD 05-23-2011 10:26 AM

OK, now we know that your /-partiton is sda1. We can use that information for getting more information. Try this:
Code:

sudo mount /dev/sda1 /mnt
cat /mnt/boot/grub/config

and post the output.

Yongle 05-23-2011 10:58 AM

Quote:

Originally Posted by TobiSGD (Post 4364649)
OK, now we know that your /-partiton is sda1. We can use that information for getting more information. Try this:
Code:

sudo mount /dev/sda1 /mnt
cat /mnt/boot/grub/config

and post the output.

I have done as you asked but output is "No such file or directory"

If I leave out the word "config" and type in "cat /mnt/boot/grub/"

output is "It is a directory"

TobiSGD 05-23-2011 11:05 AM

Sorry, the correct command is cat /mnt/boot/grub.grub.cfg
I should think first and then type.

Yongle 05-23-2011 11:26 AM

Quote:

Originally Posted by TobiSGD (Post 4364684)
Sorry, the correct command is cat /mnt/boot/grub.grub.cfg
I should think first and then type.

Is this what you are expecting to see?

ubuntu@ubuntu:~$ cat /mnt/boot/grub/grub.cfg


#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
set have_grubenv=true
load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
set saved_entry="${prev_saved_entry}"
save_env saved_entry
set prev_saved_entry=
save_env prev_saved_entry
set boot_once=true
fi

function savedefault {
if [ -z "${boot_once}" ]; then
saved_entry="${chosen}"
save_env saved_entry
fi
}

function recordfail {
set recordfail=1
if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
insmod vbe
insmod vga
}

insmod part_msdos
insmod ext2
set root='(hd0,msdos1)'
search --no-floppy --fs-uuid --set 4f437723-3d14-4ae6-9cdc-f9b61f0a84d3
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=640x480
load_video
insmod gfxterm
fi
terminal_output gfxterm
insmod part_msdos
insmod ext2
set root='(hd0,msdos1)'
search --no-floppy --fs-uuid --set 4f437723-3d14-4ae6-9cdc-f9b61f0a84d3
set locale_dir=($root)/boot/grub/locale
set lang=en
insmod gettext
if [ "${recordfail}" = 1 ]; then
set timeout=-1
else
set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Ubuntu, with Linux 2.6.35-22-generic' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod part_msdos
insmod ext2
set root='(hd0,msdos1)'
search --no-floppy --fs-uuid --set 4f437723-3d14-4ae6-9cdc-f9b61f0a84d3
linux /boot/vmlinuz-2.6.35-22-generic root=UUID=4f437723-3d14-4ae6-9cdc-f9b61f0a84d3 ro quiet splash
initrd /boot/initrd.img-2.6.35-22-generic
}
menuentry 'Ubuntu, with Linux 2.6.35-22-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod part_msdos
insmod ext2
set root='(hd0,msdos1)'
search --no-floppy --fs-uuid --set 4f437723-3d14-4ae6-9cdc-f9b61f0a84d3
echo 'Loading Linux 2.6.35-22-generic ...'
linux /boot/vmlinuz-2.6.35-22-generic root=UUID=4f437723-3d14-4ae6-9cdc-f9b61f0a84d3 ro single
echo 'Loading initial ramdisk ...'
initrd /boot/initrd.img-2.6.35-22-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos1)'
search --no-floppy --fs-uuid --set 4f437723-3d14-4ae6-9cdc-f9b61f0a84d3
linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos1)'
search --no-floppy --fs-uuid --set 4f437723-3d14-4ae6-9cdc-f9b61f0a84d3
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
if [ "x${timeout}" != "x-1" ]; then
if keystatus; then
if keystatus --shift; then
set timeout=-1
else
set timeout=0
fi
else
if sleep --interruptible 3 ; then
set timeout=0
fi
fi
fi
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f $prefix/custom.cfg ]; then
source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

TobiSGD 05-23-2011 11:37 AM

Yes, that is what I expected to see. Please post the output of
Code:

blkid
so that we can compare the UUIDs of your disk with the ones in the config file.

Yongle 05-23-2011 11:58 AM

Quote:

Originally Posted by TobiSGD (Post 4364717)
Yes, that is what I expected to see. Please post the output of
Code:

blkid
so that we can compare the UUIDs of your disk with the ones in the config file.

Cursor goes onto next line and there is no output when I enter "blkid" on the command line.

TobiSGD 05-23-2011 12:05 PM

Maybe on Ubuntu you have to put a sudo in front of it, I don't know for sure. On Slackware this is not needed.
Alternatively you can post the output of
Code:

ls -l /dev/disk/by-uuid/

Yongle 05-23-2011 02:32 PM

Quote:

Originally Posted by TobiSGD (Post 4364755)
Maybe on Ubuntu you have to put a sudo in front of it, I don't know for sure. On Slackware this is not needed.
Alternatively you can post the output of
Code:

ls -l /dev/disk/by-uuid/

I hope this is what you need:

/dev/loop0: TYPE="squashfs"
/dev/sda1: UUID="4f437723-3d14-4ae6-9cdc-f9b61f0a84d3" TYPE="ext4"
/dev/sda5: UUID="99013e39-9eba-4cab-b3b4-a3592cf0b961" TYPE="swap"

TobiSGD 05-23-2011 03:26 PM

Yes that was what I needed. Sadly, all your configuration seems to be totally OK, I don't know why it cannot find the /-partition.

Anyone else a suggestion?

Yongle 05-23-2011 05:05 PM

Quote:

Originally Posted by TobiSGD (Post 4364967)
Yes that was what I needed. Sadly, all your configuration seems to be totally OK, I don't know why it cannot find the /-partition.

Anyone else a suggestion?

thank you for your efforts


All times are GMT -5. The time now is 06:36 AM.