-   Linux - Kernel (
-   -   kernel headers are missing (

igor012 02-23-2012 11:52 AM

kernel headers are missing
I have compiled my kernel (3.1.2) from source and it's working well. But recently i needed to install some drivers and they're requiring my kernel header files. The thing is they are nowhere and I don't know how to get them.

I have tried from source folder make headers_install INSTALL_HDR_PATH=/tmp/header but it return me

  CHK    include/linux/version.h

  CHK    include/generated/utsrelease.h

  HOSTCC  scripts/basic/fixdep

In file included from /usr/include/bits/posix1_lim.h:157:0,
                from /usr/include/limits.h:145,         
                from /usr/lib64/gcc/x86_64-suse-linux/4.6/include-fixed/limits.h:169,
                from /usr/lib64/gcc/x86_64-suse-linux/4.6/include-fixed/syslimits.h:7,
                from /usr/lib64/gcc/x86_64-suse-linux/4.6/include-fixed/limits.h:34, 
                from scripts/basic/fixdep.c:114:                                     
/usr/include/bits/local_lim.h:39:26: fatal error: linux/limits.h: No such file or directory
compilation terminated.                                                                   
make[1]: *** [scripts/basic/fixdep] Error 1                                               
make: *** [scripts_basic] Error 2

I am a bit confused now. Can someone help me ?

Thank you

EDDY1 02-23-2012 12:06 PM

What distro are you using the kernel headers shoud be available thru it's package Manager.
Sorry you're using suse

igor012 02-23-2012 02:11 PM

Am i not supposed to create them (the headers)?

EDDY1 02-23-2012 02:22 PM

The kernel headers allow you to build drivers or recompile, they help you in creating

sundialsvcs 02-23-2012 04:49 PM

The "kernel headers" are a portion of the source-code of the Linux kernel that you are running: specifically, the font=courier]*.h[/font] files.

You will find that your system has two packages available, both of them probably optional: the kernel headers, and the full kernel source.

Software that needs to have up-to-date definitions of any kernel-related constant or data structure, e.g. to properly make a system call of some sort, will need the header-file information. I install it routinely.

igor012 02-24-2012 07:44 AM

I have finally solved my problem. I installed more recent drivers... And no errors

It's seems to be a problem with 3.1.x kernel and old nvidia drivers.

All times are GMT -5. The time now is 10:27 PM.