LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices


Reply
  Search this Thread
Old 03-12-2008, 06:16 PM   #1
jzimm0007@msn.com
Member
 
Registered: Aug 2007
Location: Hamilton, OH
Distribution: fedora 8
Posts: 31

Rep: Reputation: 15
Kernel 2.6.24.3-12 ata2.00 failed to identify (io error, err_mask=0x4)


Hello. I updated to the latest kernel with the package updater (2.6.24.3-12) and am getting the following on boot:
ata2: Sata link up 3.0 Gbps (SStatus 123 SControl 300)
ata 200: failed to identify (io error, err_mask=0x4)
ata2: failed to recover some devices retrying in 5 secs
"booting has failed"
I guess I should tell you that my motherboard is an msi k9a platinum. It has 4 sata connections. The bios is set on native IDE mode which didn't work. If I change it to legacy IDE mode, it works fine. AHCI mode doesn't work either. Windows usually keeps rebooting if I change this setting (at least it has in the past). I will try to boot windows and then update this shortly... Okay, the computer posts fine if you save changes and exit from the bios, but when you boot into fedora, restart it then it won't post, it says 4th ide master error press F1 to resume, I hit F1 and I see a blank screen with a blinking cursor (No grub menu). In other words the computer won't post in legacy IDE, I need native IDE to work.
Could someone please tell me how to fix this if it is a bug?

Last edited by jzimm0007@msn.com; 03-13-2008 at 06:36 PM. Reason: updated information
 
Old 03-14-2008, 11:13 AM   #2
mether
Member
 
Registered: Mar 2007
Distribution: RHEL, Fedora, Open Suse
Posts: 151

Rep: Reputation: 31
From the initial check it looks like just a warning :

<snip>
if (ata_msg_warn(ap))
ata_dev_printk(dev, KERN_WARNING, "failed to IDENTIFY "
"(%s, err_mask=0x%x)\n", reason, err_mask);
return rc;
</snip>
As you mentioned that this is stopping the system from boot..I am also confused.
 
Old 03-21-2008, 12:34 AM   #3
jzimm0007@msn.com
Member
 
Registered: Aug 2007
Location: Hamilton, OH
Distribution: fedora 8
Posts: 31

Original Poster
Rep: Reputation: 15
They need to do something about it, because the next kernel did the same thing. I think it was 2.6.24.3-34
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel 2.6.24.3-12 ata2.00 failed to identify (io error, err_mask=0x4) jzimm0007@msn.com Linux - Kernel 1 03-13-2008 01:11 PM
How do physically identify a failed RAID disk? horde Linux - General 5 02-17-2008 05:23 AM
kernel: vesafb: probe of vesafb0 failed with error -6 Toadman Mandriva 0 05-28-2005 10:13 PM
online_update failed - ERROR(Media:connection failed)[Connect failed] rover SUSE / openSUSE 8 02-22-2005 08:57 AM
kernel 2.6.8 compile error mkinitrd failed mcalizo Linux - Software 0 11-30-2004 02:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel

All times are GMT -5. The time now is 07:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration