-   Linux - Kernel (
-   -   Intel ATOM D945GCLF kernel problems (

neilneil2000 06-01-2008 07:16 AM

Intel ATOM D945GCLF kernel problems
I have just bought one of these lovely Intel Atom boards:

which has replaced the Athlon XP I was running initially.

I now have everything up and running with kernel 2.6.22-14-generic

However attempting to load

2.6.22-16-generic or

causes the boot process to fail at modprobe.

Does anyone have any ideas why this is happening?

P.S I was running 22-17 with the athlon XP since it was released without a problem.

XavierP 06-01-2008 07:26 AM

What do the logs show it's sticking on? How long does it stick for - I have had, a while back I'll add, a situation where I had compiled something in that wasn't there and the install hung while it waited to time out and move onto the next piece of hardware.

neilneil2000 06-01-2008 12:26 PM

tty1 shows:


Starting up ...
Loading, please wait...
Check root= bootarg cat /proc/cmdline
or missing modules, devices: cat /proc/modules ls/dev
ALERT /dev/disk/by-UUID/*UUID HERE* does not exist.  Dropping to shell

tty8 shows:


udevd-event[1330]: run_program: /sbin/modprobe abnormal exit

BusyBox v1.1.3 (Debian 1:1.1.3-5ubuntu12) Built-in shell (ash)
Enter help for a list of built-int commands.


I can get the output from /var/messages/ and /var/syslog if you want but I'll have to type it all in as the ethernet port is now refusing to work on it!...DOH!

XavierP 06-01-2008 03:10 PM

Have a look at and and and see if any of the suggestions there fixes the problem.

delboy711 06-02-2008 03:29 PM

I just got one of those boards too and had a similar problem running Mandriva with kernel

It segfaults while modprobing the RTL8101E ethernet with module r8169

The solution for me was to disable Ethernet in BIOS, install a newer kernel, ( and then re enable ethernet.

Now it works great.

neilneil2000 06-03-2008 03:39 PM

I have tried disabling the ethernet and in the BIOS and my gosh it worked! However, even the latest ubuntu distro didn't like it.

For the time being I have a PCI ethernet card that I am using, so thats a bit of a work around. I'd like to use the on board one at some point though. Hopefully this issue will be fixed soon!

delboy711 06-04-2008 07:45 AM

Just a footnote for people searching on this issue.
Mandriva have issued a new official kernel to fix this problem.

neilneil2000 06-24-2008 01:27 PM

Just a quick update on this issue:

Kernel 2.6.24-19-generic boots OK but I have not yet verified whether or not the port actually works!

fortran01 10-29-2008 12:39 PM

I tried the patch from the mainline kernel:


All times are GMT -5. The time now is 10:29 AM.