-   Linux - Kernel (
-   -   how to switch linux boot loader from syslinux to grub? (

nickleus 08-29-2006 07:20 AM

how to switch linux boot loader from syslinux to grub?
i have searched and searched, but i can't find the answer i'm looking for. i don't know how the heck this red hat 9 machine got syslinux as it's boot loader, but i want to change it to grub and i can't seem to figure out how to do this. there is so little about syslinux on the internet and the wierd thing is that there is no syslinux.cfg on this rh9 machine either, but during boot i can clearly see that it is booting using syslinux 2.00.

i ran:

grub-install /dev/sda1
and got this output:

# this device map was generated by anaconda
(fd0) /dev/fd0
(hd0) /dev/sda
just curious, when i run:

i get this:

Filesystem          1K-blocks      Used Available Use% Mounted on
/dev/sda2            67860000  16476208  47936564  26% /
/dev/sda1              100692    25789    69704  28% /boot
none                  1032444        0  1032444  0% /dev/shm

would that output from grub-install be correct then?

after i ran grub-install, i restarted the machine, but it still boots with syslinux. the thing is that i upgraded my kernel and rebooted, but the new kernel isn't being used, so i'm guessing that syslinux is crap and doesn't automatically update stuff like that, whereas both the grub.conf and lilo.conf were automatically updated. i don't know why i have 3 different boot loaders installed either. but anyways i want to get rid of syslinux and use grub. any help?

syg00 08-29-2006 07:33 AM

I'm surprised you can't rectify this from the RedHat CD in rescue mode.
You installed to the partition, not the MBR - try "grub-install /dev/sda" if you want grub as your boot-loader.
You'll need to ensure your menu.lst/grub.conf is valid.

Note I know nothing of how syslinux works/behaves.

nickleus 08-29-2006 07:54 AM

that didn't seem to help. can i change my boot loader in graphical install/upgrade, while still keeping everything else on the system untouched? i tried it and in the very beginning it said "no hard drives were found. would you like to pick drivers now?" so i aborted.. why would something like this be so difficult to do (or poorly documented) in a normal logged in session? wierd.

ndarkduck 09-26-2009 03:23 PM

grub-install /dev/driveXXX writes to sector 0 the bootloader

you must then issue the next commands to grub like
root (hd#,#)
initrd /boot/initrdlocationname
kernel /boot/kernelfilename

# = Numbers

Please if you found a solution to your problem write about it and share the knowlege.

All times are GMT -5. The time now is 03:26 PM.