Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Linux - Kernel This forum is for all discussion relating to the Linux kernel.


  Search this Thread
Old 10-14-2007, 03:07 AM   #1
Registered: Sep 2004
Distribution: Debian Testing / Unstable
Posts: 180
Blog Entries: 1

Rep: Reputation: 32
How can I get LAPIC timer to run instead of the PIT timer?

I have two machines, both of which have APIC. Custom built kernels (2.6.21) on both, and both say they found and enabled the local APIC. But one machine uses the LAPIC timer while the other uses the system timer (IRQ 0). What configuration items do I need to set to get the LAPIC timer to be used?

I've read all the kernel code I can for today and done two kernel builds (adding HPET and HPET_TIMER support) but still I can't get the LOC timer to

Thanks in advance for helping on this problem.
Old 10-16-2007, 10:59 PM   #2
Registered: Sep 2004
Distribution: Debian Testing / Unstable
Posts: 180

Original Poster
Blog Entries: 1

Rep: Reputation: 32
Some small progress

Booted Debian reference kernel 2.6.18-4-686 to see what would happen on the
machine which didn't have any lapic interrupts. Both timers were firing with that kernel, don't know why, but that's not what I wanted. Good to know that the hardware and BIOS did indeed support lapic timer. Also, by adding kernel command-line parm 'apic=debug' I could see it calibrating and
initializing the lapic timer.

Recompiled kernel for the lapic/no pit machine to alter a few non-timer related things, booted it up and found that now both pit and lapic timers firing. AAARRRRGHHH. Added kernel command-line parm 'nolapic_timer' to disable and found that made it boot with '0' lapic interrupts (without it,
there are at least a few interrupts for the timer interrupt which is not ultimately chosen; these happen when the kernel is going through the decision tree about which timer(s) to use).

Need to find out how to disable the PIT timer and I think I'll be OK (lapic timer only). The code (/kernel top level/arch/i386/kernel/i8253.c) says
the 'HPET replaces the PIT when enabled", but there's got to be another way
the PIT is disabled because that was what was happening on this machine when I started this thread (before I built the last kernel).

I really wish there was a kernel command line parm for this, then I could at least be in the place I wanted to be and trace my way back to see how I got there lol


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
C timer ieatsplaydoh Programming 12 05-02-2007 07:36 PM
Still need help with timer davidguygc Programming 1 04-25-2007 09:50 PM
Multimedia timer (SMP friendly timer) bigqueso Linux - Kernel 0 03-15-2007 04:49 PM
A timer LOUDSilence Programming 1 12-08-2003 06:49 AM
QT Timer kusio Linux - Software 1 04-15-2003 06:48 PM > Forums > Linux Forums > Linux - Software > Linux - Kernel

All times are GMT -5. The time now is 07:31 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration