-   Linux - Kernel (
-   -   Errors booting without cd (

Kane2002 04-06-2007 06:39 PM

Errors booting without cd
Hi guys,
Ive been trying to test some new distros lately, all with the new 2.6.20 kernel.
Installation goes fine but then when i come to boot it takes about 10 minutes to complete the boot process.

After it begins to boot it stops at a point with the message:
ata1.00: configure for UDMA/33
and a couple of other ones like that.
Then after a couple of minutes it comes up with this message:
ata1: failed to recover some devices.
and then waits 5 seconds.
It repeats this a few times, and then carries on booting.

However it does it a couple more times throughout the whole boot process.

If i put a cd in the cdrom drive (a non bootable cd) then it skips those messages ^^ and boots fine.

Anyone any idea why its doing this?

I managed to get arch working use their ide-legacy boot option, but this uses the old ide drivers and will probably not be around much longer.


fotoguy 04-07-2007 06:27 AM

Sounds like it maybe not loading the right drivers for the ata devices, It may not have the drivers compiled into the kernel, or they are modules and the modules may not be loading at boot time. Is the 2.6.20 kernel part of the distro or are you compiling one from scratch?

Kane2002 04-07-2007 08:53 AM

its part of the distro.

It occurs with the two newest versions of zenwalk and arch that ive tried.

So at the moment im stuck on an older version of zenwalk, and a version of arch that is relying on the old ide drivers.

Is there anyway of determining which, of the problems you suggested, it might be?


fotoguy 04-08-2007 02:19 AM


Originally Posted by Kane2002
Is there anyway of determining which, of the problems you suggested, it might be?

This is the hard part, unfortunately I cannot be 100% sure that this is the problem. It does how ever, looks very similar to a problem I had last week. I have just finished a few live cd projects, I went back to my old uni and show a few of my tutors my projects.

I tried booting them up on the dell computers in one of the labs, but the dells were running sata drives. I had similar errors to yours and it took about 5-6 minutes for it to finally boot up to the login screen.

A possible solution, if it's like most distros, it will have a initrd.gz file that boots with the kernel, this file is used to load modules for devices that have not be compiled into the kernel, ususally for special devices like sata, raid , scsi etc....that need to be loaded before the operating system boots. You may need to create a new initrd.gz file to go with the 2.6.20 kernel that loads the right modules for you. There is a program called mkinitrd that will make a new initrd.gz for you, your distro may already have it.

A possible reason that the earlier version works is that the developer had compiled support into the kernel or as a module in the initrd.gz file, and with the later kernel since they support a lot more hardware, they may have only compiled it as a module and may not have added to the initrd.gz.

All times are GMT -5. The time now is 08:30 PM.