-   Linux - Kernel (
-   -   Downgrade kernel to 2.6.21 (

AnushKumar 02-04-2011 04:34 AM

Downgrade kernel to 2.6.21
Hi all,

I need help regarding installing an older kernel on my fedora box currently running a 2.6.33 kernel (FC13).
I am in need to install an older kernel as i have to develop PCI drivers for the 2.6.21 kernel.

I tried to compile the kernel source from but it fails at some point. Tried to fix the errors but ended up with more errors (Guess im not good at it).
Tried to patch it too, still unsuccessful compilation.

I tried to compile a 2.6.36 kernel just to make sure im doing the right steps and i succeeded without errors and worked fine. Was even able to remove the kernel 2.6.36 properly and completely once i was done.

But now i am in dire need of the 2.6.21 kernel so please suggest me a solution.

In case anyone was wondering wat errors i got when compiling the 2.6.21 kernel from
Im posting it here


HOSTCC  scripts/unifdef
scripts/unifdef.c:209: error: conflicting types for ‘getline’
/usr/include/stdio.h:673: note: previous declaration of ‘getline’ was here
make[2]: *** [scripts/unifdef] Error 1
make[1]: *** [headers_install] Error 2
make: *** [vmlinux] Error 2

Was not sure if i patched the kernel properly so tried with
Got the same error with the kernel.

Followed the instructions on this link to compile the kernel...

prodev05 02-04-2011 05:33 AM

You are compiling version(2.6.21) source with version(2.6.36) source. Instead of compiling this. Download the exact kernel rpm and install it. Remember you should not do upgrade. You should do only install.

AnushKumar 02-05-2011 12:28 AM

Hey Arun,

Thanks for replying...

I managed to compile the 2.6.21 Kernel on my PC.

I didnt quite understand wat u meant by this...

Originally Posted by prodev05 (Post 4248131)
You are compiling version(2.6.21) source with version(2.6.36) source.

Just to be clear I had downloaded three kernel sources 2.6.21, and 2.6.36
I compiled 2.6.36 with no errors whatsoever and installed it... Worked like a charm...
But when i tried to compile the 2.6.21 or Kernels I got above errors.
In all the cases I was compiling on the default 2.6.33 PAE kernel that comes along with Fedora 13...
Besides the kernel I am compiling should not make any difference as its the GCC and GLIBC versions that cause problems when compiling (If I am right).

Anyways, I managed to clear the error by renaming the getline function to some other name where ever it was used...
I finished compiling the kernel but I am yet to install it.
I post here if I face any more problems. (Which I will ;) )

All times are GMT -5. The time now is 12:54 PM.