-   Linux - Kernel (
-   -   Compiling debian arm for NSLU2 - arm-linux-gnueabi-objdump not found (

ergosteur 10-19-2010 04:08 PM

Compiling debian arm for NSLU2 - arm-linux-gnueabi-objdump not found
I'm trying to build my own custom kernel for my NSLU2. I'm currently running Debian squeeze with 2.6.32-5-ixp4xx #1 Sat Sep 18 10:37:19 UTC 2010 armv5tel. However this kernel does not include fb terminal support or the DisplayLink (udlfb) module - I want to use my Samsung U70 monitor with it.

I installed build-essential, kernel-package, linux-source-2.6.32.
Extracted the kernel source, ran make oldconfig and make menuconfig, enabled the DisplayLink driver.

problem is when i run make-kpkg, it eventually errors out with some missing files:

This is kernel package version 12.036.
test ! -f scripts/package/builddeb.kpkg-dist || mv -f scripts/package/builddeb.kpkg-dist scripts/package/builddeb
test ! -f scripts/package/Makefile.kpkg-dist || mv -f scripts/package/Makefile.kpkg-dist scripts/package/Makefile
/usr/bin/make EXTRAVERSION=-nslu2-displaylink ARCH=arm \
CROSS_COMPILE=arm-linux-gnueabi- zImage
make[1]: Entering directory `/usr/src/linux-source-2.6.32'
scripts/kconfig/conf -s arch/arm/Kconfig
make[1]: Leaving directory `/usr/src/linux-source-2.6.32'
make[1]: Entering directory `/usr/src/linux-source-2.6.32'
CHK include/linux/version.h
make[2]: `include/asm-arm/mach-types.h' is up to date.
CHK include/linux/utsrelease.h
SYMLINK include/asm -> include/asm-arm
CALL scripts/
CHK include/linux/compile.h
CC init/version.o
/bin/sh: arm-linux-gnueabi-objdump: not found
LD init/mounts.o
/bin/sh: arm-linux-gnueabi-ld: not found
make[2]: *** [init/mounts.o] Error 127
make[1]: *** [init] Error 2
make[1]: Leaving directory `/usr/src/linux-source-2.6.32'
make: *** [debian/stamp/build/kernel] Error 2

I'm at a complete loss as to where to get the arm-linux-gnueabi files. Is it something I can just apt-get? or do I need a toolchain or something?

Mara 10-23-2010 05:01 PM

The missing files you get come from ARM toolchain. Look for a package like 'linux-build',

ergosteur 10-29-2010 09:51 PM

Hmm can't seem to find any linux-build packages in standard repos. I tried using the emdebian repo, but seems that's only for cross-compiling.

ergosteur 10-30-2010 11:24 AM

Managed to cross-compile the kernel.
Installed the arm toolkit from, and the 'lzma' package.
Then copied /boot/config-2.6.32-5-ixp4xx to my i386 build box in /usr/src/linux-source-2.6.32/.config.
cd to /usr/src/linux-source-2.6.32

make oldconfig
make menuconfig

Enabled Graphics support for FB console and DisplayLink module.

then make-kpkg and installed the resulting deb on the NSLU2.

Now I'm trying to figure out how to get the NSLU2 to boot the new kernel...

All times are GMT -5. The time now is 03:52 PM.