LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
Search this Thread
Old 08-24-2006, 08:15 PM   #1
BizHat.com
Member
 
Registered: Jul 2004
Location: India
Distribution: RH, RHEL, CentOS
Posts: 46

Rep: Reputation: 15
CentOS Kernel Upgrade Error


Hi,

I am using CentOS release 3.7 (Final) on my server.

Kernel is Linux 2.6.8.1 #3 SMP

Today i tried to upgrade kernel with yum thinking it will be latest version than what i am having.

But it installed older kernel than the one one i have - 2.4.21-47.EL

I tried compiling from source, but on "make install", i get error

Quote:
sh /usr/local/src/linux-2.6.17.11/arch/i386/boot/install.sh 2.6.17.11
arch/i386/boot/bzImage System.map "/boot"
No module ata_piix found for kernel 2.6.17.11, aborting.
mkinitrd failed
make[1]: *** [install] Error 1
make: *** [install] Error 2
The server have SATA Hard Disk. I think i need to enable ata_piix module. But i can't find HOW-TO enable this.

Can anyone tell me how to fix error or where i can find latest version of Kernel RPM that work with CentOs 3.7 ?

Thanks,

Yujin
 
Old 08-25-2006, 06:01 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
CentOS 3.X is based on the 2.4 kernel series so you will not find a built 2.6 kernel for this.

The SCSI_ATA_PIIX support is in the SCSI device support--> SCSI low-level drivers section;

#
# SCSI low-level drivers
#
# CONFIG_ISCSI_TCP is not set
# CONFIG_BLK_DEV_3W_XXXX_RAID is not set
# CONFIG_SCSI_3W_9XXX is not set
# CONFIG_SCSI_ACARD is not set
# CONFIG_SCSI_AACRAID is not set
# CONFIG_SCSI_AIC7XXX is not set
# CONFIG_SCSI_AIC7XXX_OLD is not set
# CONFIG_SCSI_AIC79XX is not set
# CONFIG_MEGARAID_NEWGEN is not set
# CONFIG_MEGARAID_LEGACY is not set
# CONFIG_MEGARAID_SAS is not set
CONFIG_SCSI_SATA=m
CONFIG_SCSI_SATA_AHCI=m
# CONFIG_SCSI_SATA_SVW is not set
CONFIG_SCSI_ATA_PIIX=m
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Audit Support Unavaible error when booting after kernel upgrade abefroman Red Hat 2 03-21-2013 08:32 AM
Centos - After upgrade to KDE 3.5. issues tnbk00 Red Hat 7 08-21-2006 03:41 PM
Keep getting error while trying to upgrade to 2.6 kernel M$ISBS Linux - Kernel 4 07-05-2006 01:10 AM
Redhat AS server upgrade via Yum using CentOS repository? yilang Red Hat 1 04-15-2006 10:02 PM
Kernel upgrade error..... tinaa Linux - Software 3 07-21-2003 01:14 PM


All times are GMT -5. The time now is 07:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration