-   Linux - Kernel (
-   -   centos 6 fails to load file system while booting (

khhuff 12-23-2012 06:49 PM

centos 6 fails to load file system while booting
Upon rebooting I receive the error;
dracut:/ can't mount file system. This is Centos 6 on a usb live flash drive. It was working fine until I started a download. My question is how do I direct the filesystem to be loaded with the dracut shell, or does it have to be done within the actual files. This is my first attempt at fixing a kernel instead of just doing a re-install so any help would be appreciated.
Thank You

John VV 12-23-2012 09:49 PM

What did you download ?

dracut normally is called if a new kernel is insalled
if you have a nvidia ore AMD 3d card for a new driver

centOS by default is using the nouveau driver for a nvidia card

you could boot into "single user" mode
edit the end of the kernel line in grub.conf / menu.lis
or during the 3 sec. countdown during boot up

hit the space bar to kill the 3 sec. count
Then hit "e" ( for edit )
down arrow to get to the kernel line
add a blank space and a 1 to the end of the kernel line
then enter
then "b" ( for boot )

khhuff 12-24-2012 09:55 AM

I had attempted to download metasploit for centos, and it was after the download that the problem occurred. I have tried what you posted and it still comes up with kernel panic - can't mount file system

John VV 12-24-2012 10:21 AM

What exact commands / procedure did you do ?

was it the *.run ( 32 bit or 64 bit) from the web site ?

or the SVN source pull

svn ls
were you fallowing some guide?
if so please past a link

something like this ?
or the install guide?

khhuff 12-24-2012 10:42 AM

I was downloading from this link:

I just clicked on 32-bit and it downloaded, but I could not open it to install, and after that I could not open up the computer files from the desktop, nor any web browsers, that is why I did a restart and then encountered the kernel panic. All I could find out to do was edit the boot options with rdshell, but from there I am stuck trying to direct the file system to be loaded.

John VV 12-24-2012 12:05 PM

so you did download the .run
that is an executable file
You do not "open" it

so what exactly did you do with the .run ?

you normally run the ".run" program
it is a type of installer

so the 32 bit ?
i take it that this is a old computer that is using a 32 bit hardware
you dl it
open a terminal

su -
cd / to/the/location/you/saved/the/file
chmod +x

Fallow the instructions in the "Linux_InstallationGuide.pdf"
the full install instructions are in the pdf -- i am looking at it as i type

cent like RHEL dose not use"sudo" by default
use "su" or " su -"
or set up sudo ( disabled by default)

All times are GMT -5. The time now is 12:49 PM.