LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Kernel (https://www.linuxquestions.org/questions/linux-kernel-70/)
-   -   Cannot load md5.ko module (https://www.linuxquestions.org/questions/linux-kernel-70/cannot-load-md5-ko-module-911608/)

x_terminat_or_3 11-03-2011 05:21 AM

Cannot load md5.ko module
 
Hi
I am trying to mount a CIFS share, which keeps failing.
It seems to be related to the fact that the md5 module isn't loaded.
I have tried to load the module, but it keeps failing with
Quote:

FATAL: Error inserting md5 (/lib/modules/3.0-ARCH/kernel/crypto/md5.ko.gz): Unknown symbol in module, or unknown parameter (see dmesg)
dmesg says:
Quote:

md5: Unknown symbol md5_transform (err 0)
I have tried the following:
* reinstalling the kernel package (pacman -S linux), and rebooting
* running depmod then modprobe md5
* loading other modules, modprobe hmac (worked)

Does anyone have any ideas to fix this?
Thanks

sundialsvcs 11-04-2011 09:32 AM

Who is responsible for maintaining these packages? Clearly, the kernel module is not compatible with the kernel you have installed. Since you are using packages to maintain both, you should open a trouble-ticket with the package maintainers and wait for their assistance in resolving the problem.

Consider yourself lucky in that the kernel module loader detected the problem ... that there actually is a missing symbol. If you load a kernel module that's incompatible and don't realize it at the time, your system normally suffers instant death.

x_terminat_or_3 11-04-2011 11:12 AM

Much as I like to believe that I was convinced it is something I did wrong...

I don't have an identical machine to play with, other than the affected one that is.

However, the same kernel package loads the md5 module just fine when installed on x86_64, and on my atom. I copied the module from the atom to the affected one and tried to load it again, with exactly the same result.

My humble opinion is that this means the issue is not in the package, but somewhere else.

sundialsvcs 11-04-2011 03:43 PM

You can't "copy a module from" one system to another and merely expect it to work. Especially not if there is any possibility whatsoever that the two system-types are not exactly the same.

Remember what a kernel module is: a thing that, if accepted into the kernel of the target system, will in every way and in every sense become a part of that target system's innermost software parts. It must therefore be built for exactly that target system.

Please... the system is telling you what the problem is. Believe what it is telling you, not what you intuit the problem to be. "Don't out-think yourself."

x_terminat_or_3 11-04-2011 04:09 PM

Thanks for your help.

I've since mounted the share on another server, bypassing the problem for now. At least until Arch releases a new kernel package.


All times are GMT -5. The time now is 11:47 PM.