-   Linux - Kernel (
-   -   Bootsplash dissapears after loading some driver. (

Semash! 04-03-2012 11:33 PM

Bootsplash dissapears after loading some driver.
Hello, i finally made work my custom kernel with the bootsplash screen, but now i have another issue.

After lilo loads the OS, bootsplash screen appears on the background and i can see the "verbose" text running while my OS loads, but after loading a driver (i think it's the video one, because the whole screen blinks and gets a better resolution) the splash screen dissapears, i mean, background returns to be black, while the kernel loading information is still running (Loading fuse, etc) and time after the tty login appears.

What's causing this issue? How can i solve it?
I'll really appreciate help with this.
Thanks in advance.

Also, i've noticed that in my dmesg i get a conflicting fb hardware error just before the system blinks, updates and deletes the bootsplash screen.


fb: conflicting fb hw usage inteldrmfb vs VESA VGA. Removing conflicting driver.
Please, help!

Semash! 04-06-2012 05:16 AM

I'm still having the same problem after reinstalling the OS, recompiling a new kernel, and re-configuring it. The same thing, bootsplash shows up, and then the kernel loads another frame buffer driver, gets a new resolution and after blinking, the bootsplash isn't present.

Please, help me find a solution for this!

yustin 01-21-2013 07:58 AM

got the same problem here but only in "silent" mode.
verbose works great since i put /boot in fstab.


sundialsvcs 01-21-2013 09:49 PM

Obviously your driver by changing the screen-resolution is flipping away from wherever the splash image got loaded. Is there a way to delay the driver's initialization step until after the boot has been completed?

yustin 01-23-2013 03:12 AM

solved ...
opensuse got all the bootsplashpatches included in their kernelsources.
works fine with inteldrmfb kernel 3.7.2.

happy bootsplashing :)

update: /proc/splash seems to be broken => no progressbar

yustin 01-25-2013 09:10 AM

done ... here's the diff-file. progressbar works now.
check for further information and utils.


All times are GMT -5. The time now is 06:30 AM.