Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Linux - Kernel This forum is for all discussion relating to the Linux kernel.


  Search this Thread
Old 09-01-2012, 08:05 PM   #1
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 468

Rep: Reputation: Disabled
3.2.28 Generic Kernel in Slackware (with nvidia optimus, bumblebee)


I've been getting this error in Slackware using bumblebee with the generic kernel 3.2.28 (attachment below).

This error doesn't occur on a Slackware machine (same kernel) that doesn't have nvidia optimus.

The log is the end of syslog at the exact moment the crash occurs. I can't quit X, I can't switch to a different tty, it's just a complete freeze. Videos loop about the last millisecond of noise. The mouse also does not move.

Hopefully it's been fixed in a newer kernel version, but I don't keep up with the kernel development.
Attached Files
File Type: log 3.2.28_crash.log (7.8 KB, 13 views)
Old 09-03-2012, 05:58 AM   #2
Didier Spaier
LQ Addict
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,765

Rep: Reputation: 2691Reputation: 2691Reputation: 2691Reputation: 2691Reputation: 2691Reputation: 2691Reputation: 2691Reputation: 2691Reputation: 2691Reputation: 2691Reputation: 2691
I see two worrying lines in the log.

Firts, the last one:
Sep  1 15:45:55 TomHPdv7 udevd[1817]: could not find module by name='rtc_cmos'
I suppose that you are running Slackware -current as you are using a 3.2.28 kernel.

This is supposed to be fixed since RC3:
a/udev-182-i486-4.txz: Rebuilt.
       Commented out the entries in /lib/modprobe.d/isapnp.conf to fix
       the error attempting to load rtc_cmos. Thanks to GazL.
Is your Slackware properly uopgraded?

Alse, check the content of /etc/modrobe.d. There should be only two files in it now: README and (possibly) blacklist.nouveau.conf.
If they are others, just remove it. Noticeably, remove isapnp.conf.

Second, this one:
[drm:intel_dsm_platform_mux_info] *ERROR* MUX INFO call failed
I don't know if that caused the freeze but I suggest you investigate from there as a Google search on that returns a lot of results.

Anyhow, I see no reason to assume that your problem be kernel related, so I suggest you post it in the Slackware forum instead to get more useful answers (or click the Report button and request a moderator to move the thread there).
Old 09-07-2012, 03:10 PM   #3
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 468

Original Poster
Rep: Reputation: Disabled
Hi Didier,

I did a kernel upgrade and it was fixed, and I do properly upgrade Slackware.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Get HDMI Working With Nvidia Optimus On Ubuntu By Using Bumblebee And Synergy LXer Syndicated Linux News 0 08-21-2012 09:00 PM
Nvidia Optimus bumblebee issues nouveau - x11[drm] cannot open device speedsrfr Linux - Laptop and Netbook 1 07-31-2012 04:49 AM
Problem Nvidia Optimus Technology linux Support (bumblebee apps) jao_madn Linux - Laptop and Netbook 4 05-27-2012 07:26 AM
LXer: Bumblebee 3.0 Released (Nvidia Optimus GPU Switching For Linux) LXer Syndicated Linux News 0 01-20-2012 09:30 PM
Slackbuilds for Bumblebee - Nvidia Optimus jimmy_page_89 Slackware 5 12-31-2011 08:31 AM > Forums > Linux Forums > Linux - Software > Linux - Kernel

All times are GMT -5. The time now is 07:02 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration