LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices


Reply
  Search this Thread
Old 04-07-2021, 12:31 PM   #1
RandomTroll
Senior Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 1,557

Rep: Reputation: 248Reputation: 248Reputation: 248
'ERROR: modpost: "wakeup_cpu0" [drivers/acpi/processor.ko] undefined! ' building kernel 5.11.12


I applied the incremental patch patch-5.11.11-12.xz, make errored out:
Quote:
ERROR: modpost: "wakeup_cpu0" [drivers/acpi/processor.ko] undefined!
ERROR: modpost: "start_cpu0" [drivers/acpi/processor.ko] undefined!
To test patched-ness I ran:
Code:
xz -dc patch-5.11.12.xz | patch -p1 -R --dry-run
when ran without error. The .configs are identical.

Later that same day: it happens even after a make clean

3 days later:

I had hoped that the patch to 5.11.13 would fix this error, but it didn't. I downloaded the whole source for 5.11.13, get the same error - am I the only one? I can build 5.11.11.

Even later:

Commenting
Code:
#if defined(CONFIG_X86) && defined(CONFIG_HOTPLUG_CPU)
                /* If NMI wants to wake up CPU0, start CPU0. */
                if (wakeup_cpu0())
                        start_cpu0();
#endif
out of drivers/acpi/processor_idle.c eliminates the error

Last edited by RandomTroll; 04-10-2021 at 10:56 PM. Reason: additional information.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Building module: modpost error jnr Linux - Kernel 3 03-08-2021 03:42 PM
Problem building ath10k drivers from source (modpost errors) AndyWas Linux - Wireless Networking 2 12-13-2020 08:58 AM
[SOLVED] Undefined Variables During MODPOST dsb9938 Linux - Kernel 4 09-17-2013 08:05 PM
[SOLVED] Error inserting processor (lib/modules 2.6.26-2-686/kernaldrivers/acpi/processor EDDY1 Linux - Newbie 3 08-29-2010 01:08 AM
modpost warnings when building a driver... please help tachwali Linux - Hardware 7 08-11-2008 12:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel

All times are GMT -5. The time now is 07:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration