LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 11-15-2006, 04:15 PM   #1
ggeo
Member
 
Registered: Aug 2006
Location: Greece
Posts: 96

Rep: Reputation: 15
Smile yesterday had sound ,now don't!


Hello everyone there!

I use FC6 and i have Creative Labs SB Audigy LS
When i had FC5 my sound didn't work at all.The configuration menu recognised my sound card but it just didn't work.I heared only noise.
In FC6 i also din't hear any sound but suddenly (after i did update maybe?) my sound worked but it recognised only stereo 2.1 and not surround 5.1.
Again suddenly,today i am at the beggining!I have no sound,i hear only the noise.
I tried changing my /etc/modprobe.conf as alsa says but nothing.
If anyone knows what to do..

Thanks!
 
Old 11-15-2006, 05:03 PM   #2
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 64
Sounds like the common issue. Run the command in a terminal. Run the command ' alsamixer '. Check the volumes for master and pcm. Use arrow keys to move across and raise if set at zero. Now check and see if a MM is at the top of those bars. If so arrow over to that channel and hit the M key to unmute the channel. Exit and test for sound. To save the settings after a reboot run this command as root ' alsactl store '.

Brian
 
Old 11-16-2006, 03:59 AM   #3
ggeo
Member
 
Registered: Aug 2006
Location: Greece
Posts: 96

Original Poster
Rep: Reputation: 15
No,nothing happens
I had this problem with FC5 too
I hear only noise
 
Old 11-16-2006, 04:03 PM   #4
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 64
Check in the HCL section here. It is a link at the top or to the right. See if others have the same issue. Most Audigy I thought used the module emu10k1. List your loaded modules with the command ' lsmod '. One last thought is make sure speakers is plugged in the correct port.

Brian
 
Old 11-17-2006, 08:11 AM   #5
ggeo
Member
 
Registered: Aug 2006
Location: Greece
Posts: 96

Original Poster
Rep: Reputation: 15
I have done search and i figured that i must use ca0106
Also,i remind you that for some time suddenly i had music and suddenly gone away!

My lsmod

Module Size Used by
autofs4 25413 2
hidp 24129 2
rfcomm 46041 0
l2cap 31681 10 hidp,rfcomm
bluetooth 58917 5 hidp,rfcomm,l2cap
sunrpc 158333 1
ndiswrapper 187028 0
ip_conntrack_ftp 12081 0
ip_conntrack_netbios_ns 7105 0
ipt_REJECT 9665 1
xt_state 6337 11
ip_conntrack 56993 3 ip_conntrack_ftp,ip_conntrack_netbios_ns,xt_state
nfnetlink 11353 1 ip_conntrack
iptable_filter 7233 1
ip_tables 17669 1 iptable_filter
ip6t_REJECT 9537 1
xt_tcpudp 7361 36
ip6table_filter 7105 1
ip6_tables 18821 1 ip6table_filter
x_tables 18501 6 ipt_REJECT,xt_state,ip_tables,ip6t_REJECT,xt_tcpudp,ip6_tables
dm_mirror 33041 0
dm_multipath 22601 0
dm_mod 61529 2 dm_mirror,dm_multipath
video 21061 0
sbs 20225 0
i2c_ec 9281 1 sbs
button 10961 0
battery 14405 0
asus_acpi 20697 0
ac 9541 0
ipv6 267489 69 ip6t_REJECT
parport_pc 31205 1
lp 17033 0
parport 40841 2 parport_pc,lp
snd_ca0106 37573 1
snd_rawmidi 28737 1 snd_ca0106
snd_ac97_codec 95073 1 snd_ca0106
snd_seq_dummy 8133 0
snd_seq_oss 37185 0
snd_seq_midi_event 11841 1 snd_seq_oss
snd_seq 57137 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 12621 4 snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 46561 0
snd_mixer_oss 20545 1 snd_pcm_oss
snd_pcm 80325 3 snd_ca0106,snd_ac97_codec,snd_pcm_oss
floppy 61284 1
snd_timer 27077 2 snd_seq,snd_pcm
snd 57029 12 snd_ca0106,snd_rawmidi,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,s nd_pcm,snd_timer
soundcore 14113 1 snd
snd_ac97_bus 6593 1 snd_ac97_codec
snd_page_alloc 14281 2 snd_ca0106,snd_pcm
8139cp 28609 0
nvidia 4723188 22
8139too 31169 0
i2c_nforce2 11457 0
mii 9665 2 8139cp,8139too
pcspkr 7361 0
i2c_core 25537 3 i2c_ec,nvidia,i2c_nforce2
serio_raw 11205 0
usblp 18369 0
ide_cd 42337 7
cdrom 38625 1 ide_cd
sata_nv 15685 0
libata 102745 1 sata_nv
sd_mod 24897 0
scsi_mod 138601 2 libata,sd_mod
ext3 135369 2
jbd 63209 1 ext3
ehci_hcd 35533 0
ohci_hcd 25181 0
uhci_hcd 27725 0

I didn't find anything at the link
 
Old 11-17-2006, 05:40 PM   #6
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 64
Looks like it is seeing two sound cards. Is there onboard audio card?
If so post contents of /etc/modprobe.conf
If bios can disable the onboard sound card try that.
On reboot then the kudzu tool should correct hardware devices.
Try sound. If no sound try the alsamixer routine in above post.

Brian
 
Old 11-18-2006, 05:33 AM   #7
ggeo
Member
 
Registered: Aug 2006
Location: Greece
Posts: 96

Original Poster
Rep: Reputation: 15
I have disabled the on board card.
My /etc/modprobe.conf is

alias eth0 8139too
alias scsi_hostadapter sata_nv
alias wlan0 ndiswrapper
alias snd-card-0 snd-ca0106
options snd-card-0 index=0
options snd-ca0106 index=0
remove snd-ca0106 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-ca0106

alias snd-card-1 snd-mpu401
options snd-card-1 index=1
options snd-mpu401 index=1

remove snd-mpu401 { /usr/sbin/alsactl store 1 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-mpu401




# ALSA portion
alias char-major-116 snd
alias snd-slot-0 snd-card-0
alias snd-slot-1 snd-card-1
alias snd-card-0 snd-ca0106
alias snd-card-1 snd-via82xx
# Module options should go here
options snd-card-0 index=0
options snd-emu10k1 index=0
options snd-card-1 index=1
options snd-via82xx index=1
# OSS/Free portion
alias char-major-14 soundcore
# card #0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
# card #1
alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-12 snd-pcm-oss

I added the lines below #ALSA portion as i saw at the alsa project site
But before that (adding the lines) again i hadn't sound

Thanks !
 
Old 11-18-2006, 05:10 PM   #8
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 64
Know nothing about the #Alsa section you have added. Other than that it looks good on the modprobe.conf file. That is the correct module for the sound card you have as far as what I can find here and on the net. I am at a lost now as to why it does not work.

What is the permission of /dev/dsp

Brian
 
Old 11-19-2006, 06:15 AM   #9
ggeo
Member
 
Registered: Aug 2006
Location: Greece
Posts: 96

Original Poster
Rep: Reputation: 15
The permission is read and write
When i do /dev/dsp at console as root it says access denied
 
Old 11-20-2006, 04:22 PM   #10
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 64
Does seem odd. Doing a ls -l /dev/dsp shows crw****** for me. Is this yours?

Brian
 
Old 11-20-2006, 04:29 PM   #11
fozner
Member
 
Registered: Aug 2006
Posts: 147

Rep: Reputation: 16
Play with the settings system-config-soundcard until you hear pleasant sounds.
Hit apply and reboot.
Play an audio loop with xmms or other sound program and mess around with the sliders in kmix until you hear sound again.
Log out of KDE. This will save your session and settings. Or go into session editor and enable restart to manually-saved sessions and save your session. Now KDE will remember these settings every time it boots up, even if you mess with them later.
 
Old 11-21-2006, 10:51 AM   #12
ggeo
Member
 
Registered: Aug 2006
Location: Greece
Posts: 96

Original Poster
Rep: Reputation: 15
Yes , my /dev/dsp is crw*****

I play with kmix settings but nothing.I can hear a little bit sound .Noise is everywhere
 
Old 11-21-2006, 03:10 PM   #13
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 64
I did mention it earlier but does the card have 2 jacks for speakers? If so try the other. Other than that I am at a lost to the issue. Maybe the card you have is not the same as previous Audigy ones and the module does not work with that card.

Brian
 
Old 11-22-2006, 03:30 AM   #14
fozner
Member
 
Registered: Aug 2006
Posts: 147

Rep: Reputation: 16
You have enabled digital sound, which sounds like noise on normal speakers. Maybe right-click kmix and enable IEC958 playback and then disable it. Try clicking and un-clicking the other IEC958 switches too, especially IEC958 output.

Or get digital speakers.
 
Old 11-22-2006, 05:32 AM   #15
ggeo
Member
 
Registered: Aug 2006
Location: Greece
Posts: 96

Original Poster
Rep: Reputation: 15
I disabled IEC958 ,played with kmix but still the same noise!
I don't know what to do!!!

Thanks anyway!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I have no sound today...yesterday i did. TallAmericano Linux - Newbie 6 08-06-2006 09:12 AM
I had it working yesterday!! Kiada Linux - Networking 1 09-27-2003 05:24 AM
Today-Yesterday Axo LQ Suggestions & Feedback 6 07-15-2003 09:39 AM
Yesterday already? david_ross LQ Suggestions & Feedback 12 04-13-2003 02:59 PM
Installed yesterday need help josefalero Linux - Newbie 4 10-21-2002 09:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 01:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration