-   Linux - Hardware (
-   -   Xorg Freezes on my system (

JanusPaul 10-25-2009 09:37 PM

Xorg Freezes on my system
Not sure why I get the same result between (amd64) debian, kubuntu, xubuntu, but the screen will pixelate once the desktop is fully loaded, sometimes when an app window opens like konsole/terminal.

I've tried various combinations, with & without the GeForce PCIx, even the live CDs freeze. Please trust me when I say I exhaust searching for what's already been asked/posted/resolved before posting, yes even google, I'm at a loss... It freezes like a kernel panic because Ctrl+Alt+F1 doesn't do jack, nor Ctrl+Alt+BkSp, would dmesg have logged anything useful?

A brief hardware list:

Dell Inspiron 531
Socket AM2 AMD Athlon64 X2 3800+
nVidia GeForce 7800 GT PCIx
nVidia MCP61 PCIx (onboard)

(complete hwinfo -


fbsduser 10-25-2009 11:12 PM

the latest Xorg have the ctrl-alt-bksp disabled by default. You need to install a package called something like "nozap" or similar. With it the ctrl-alt-bksp gets enabled.

Wim Sturkenboom 10-26-2009 03:14 AM

Did you install the nvidia drivers? The nv drivers do not always work properly with nvidia cards.

smeezekitty 10-26-2009 12:00 PM

didf you try 640x480x4BPP VGA mode to see if its the video driver?

JanusPaul 10-26-2009 11:28 PM

Yeah I tried the nVidia drivers and everything loaded quicker, got to the same point and froze the same way. Correction though, the mouse cursor will continue to respond but that's it. Will try the "nozap" package thanks.

I don't think it's directly a video problem though. MemTest?

smeezekitty 10-27-2009 12:19 AM


Originally Posted by JanusPaul (Post 3733662)
I don't think it's directly a video problem though. MemTest?

more likly then not its a video problem.

Wim Sturkenboom 10-27-2009 04:03 AM

The alternative to <alt><ctrl><backspace> is <alt><printscrteen>k

Some idiot came up with the idea that users can press <alt><ctrl><backspace> by accident.

Running memtest will not hurt; at least you can eliminate a possible cause.

JanusPaul 02-21-2010 01:58 PM

Another diagnosis
Sorry for re-opening this issue, my buddy made it a Windows box for a couple months and then decided he wanted to learn Linux over many Windows related frustrations/headaches (why we all went to Linux in the first place :P).

Attempting to get Gnome working remotely GDM did come up, he did login, the GUI froze, but the machine via remote connection still worked. Xorg went into an endless loop (100% CPU usage), killed that process. When GDM came up again it just froze and wouldn't go away, etc. so I just rebooted to clear up the mess for now. dmesg revealed nothing about the issue either.

Up to the point of actually freezing the display is as it should be and then bam, it pixilates again becomes unresponsive to the GUI user.

What do I need to do to resolve this or at least diagnose it better/further, something, anything please.

Now I've got it running straight Debian from NetInstall (Lenny) or "Linux Tux 2.6.26-2-amd64 #1 SMP Thu Feb 11 00:59:32 UTC 2010 x86_64 GNU/Linux".

All times are GMT -5. The time now is 11:20 PM.