LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 12-01-2005, 05:18 PM   #1
NullDevice23
LQ Newbie
 
Registered: Feb 2005
Posts: 19

Rep: Reputation: 0
[SOLVED] xorg: Failed to load module...


Hi,

I just installed Gentoo on my laptop. Everything works fine so far , except xorg.
Im getting the following error when i try to "startx" as normal user, as well as as root:

Code:
X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.12 i686 [ELF]
Current Operating System: Linux airfilter 2.6.14-gentoo-r2 #1 PREEMPT Tue Nov 29 19:45:38 UTC 2005 i686
Build Date: 29 November 2005
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Dec  2 00:07:08 2005
(==) Using config file: "/etc/X11/xorg.conf"
Couldn't open RGB_DB '/usr/X11/lib/X11/rgb'
(EE) Failed to load module "bitmap" (module does not exist, 0)
(EE) Failed to load module "pcidata" (module does not exist, 0)

Fatal server error:
Unable to load required base modules, Exiting...


Please consult the The X.Org Foundation support
         at http://wiki.X.Org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.


XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.
Its a 1,7ghz Toshiba Tecra 9100, graphic card is a S3 SuperSavage.
I copied the xorg.conf from a webpage about that Laptop + Xorg.
Can someone please give me hint?

Last edited by NullDevice23; 12-02-2005 at 03:22 PM.
 
Old 12-02-2005, 12:47 PM   #2
mewgle
Member
 
Registered: Mar 2005
Distribution: Mandrake 10.1
Posts: 58

Rep: Reputation: 15
Could you post your xorg.conf please?
 
Old 12-02-2005, 02:29 PM   #3
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,391

Rep: Reputation: Disabled
Re: xorg: Failed to load module...

Quote:
Originally posted by NullDevice23

(EE) Failed to load module "bitmap" (module does not exist, 0)
(EE) Failed to load module "pcidata" (module does not exist, 0)
Try removing bitmap and pcidata from modules section in xorg.conf
 
Old 12-02-2005, 03:22 PM   #4
NullDevice23
LQ Newbie
 
Registered: Feb 2005
Posts: 19

Original Poster
Rep: Reputation: 0
OK, thanks. It's fine now =)
 
Old 08-05-2006, 09:01 AM   #5
gr0sshirn
LQ Newbie
 
Registered: Aug 2006
Location: Germany
Distribution: Gentoo [2.6.17-gentoo-r7]
Posts: 8

Rep: Reputation: 0
oO

i've got the same problems...

what have u done?


----
i've fixed it, too
if anyone has the same problem and needs help > ask me
icq 215288158
mail gecko@facemodding.de

Last edited by gr0sshirn; 08-07-2006 at 12:06 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg -- (EE) Failed to load module "glx" (loader failed, 7) windowsrefugeeX Linux - Software 10 09-23-2009 05:51 PM
Failed to load the NVIDA kernal module magisbladius Slackware 9 04-14-2005 04:27 PM
Xorg - (EE) Failed to load module "i810".... frogboy Linux - Laptop and Netbook 1 10-17-2004 12:11 AM
Xorg - (EE) Failed to load module "i810".... frogboy Linux - Software 2 10-16-2004 11:39 AM
(EE) Failed to load module error Seventh Linux - Newbie 8 02-23-2004 02:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration