LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 12-23-2003, 04:01 AM   #1
RinGz
LQ Newbie
 
Registered: Oct 2003
Location: Atlanta, GA and Dallas, TX
Posts: 23

Rep: Reputation: 15
xmms stalls...audio device in use?


okay, I listening to streaming MP3s as my normal source of music. If I go off for a long while (oh, 4...5 hours), the streaming connection usually craps out, and then nothing is played for a while. When I come back to listen to more music, double-click on a song in the playlist, it just locks up. It won't do anything at all, so I have to open up a console window, and kill -9 it
Then when I open it up again to try to play music, it freezes up the same way, except the window isn't there (cuz it hasn't opened yet). I tried running it from a console window to see if there was any debug output, but there wasn't. The last time this happened, I restarted my compy and seem to remember getting an error about the audio device. I'll try again and repost what that was.

okay, from memory, there was a line after the Sending all processes the TERM signal (not RIGHT after, but a few lines down):

<driver for audio device>, drain_dac, dma timeout
or something like that. Any ideas?

Last edited by RinGz; 12-23-2003 at 04:07 AM.
 
Old 12-23-2003, 07:48 PM   #2
RinGz
LQ Newbie
 
Registered: Oct 2003
Location: Atlanta, GA and Dallas, TX
Posts: 23

Original Poster
Rep: Reputation: 15
okay, it happened again, and then I tried to run a play command from the console, and it said:
sox: Can't open output file '/dev/dsp': Device or resource busy

Is there a way I can restart the audio service and clear out any usage of the audio device some way?

EDIT
I just got mail from logwatch...it says:

WARNING: Kernel Errors Present
end_request: I/O error, dev 16:00 (hdc)...: 141Time(s)

Last edited by RinGz; 12-24-2003 at 03:15 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why I can't use USB audio device when onboard audio enabled in install RockyZ Fedora 6 03-28-2009 07:40 PM
Real Player and XMMS "Cannot open audio device" - SuSE 9 pro hand of fate Linux - Software 16 07-01-2007 09:45 PM
No audio after using xmms gobi_dgm Linux - Newbie 2 05-07-2005 12:45 PM
Do xmms can lock the audio device? 7ux_spirit Linux - Software 3 04-17-2004 05:34 PM
XMMS problem : ** WARNING **: oss_open(): Failed to open audio device (/dev/dsp): sureshrk19 Slackware 4 04-01-2004 09:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 12:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration