-   Linux - Hardware (
-   -   X11 Expert Needed (

hilltop*Tech 06-07-2005 07:34 PM

X11 Expert Needed
Ok, I admit it - I've been beat. I've spent weeks trying to get X working on a Sony FS550 with a Intel 915GM video card with a resolution of 1280x800. I've tried Fedora Core 3, Fedora Core 4, CentOS 4 and Suse 9.3. I've had the best success with Suse. At least the drivers loaded, but was only able to achieve a resolution of 1024x768.

I've been running Linux on notebooks for almost 10 years and having to work with Windows on this machine is slowly putting me to my grave. This is a great notebook and all I want is to run Linux on it.

If someone is interested in getting X running on this machine with a resolution of 1280x800 - name your price. I will install any of the OS's listed above and provide you full SSH access to the machine. I would like either the i810 or i915 drivers and not the vesa driver configured.

If your interested, let me know

Thanks in advance.

anonobomber 06-08-2005 12:08 PM

umm, thats pretty easy to do. All you have to do is use modelines to get that resolution and you can even use this online modeline creator!

hilltop*Tech 06-08-2005 02:10 PM

I would have thought the same thing. I created a modeline with the values that were returned from gtf and was unsuccessful in getting the 1280x800 resolution. Even though this is the preferred resolution of the notebook - its not in the bios of the i915GM chip. I also tried the 915resolution tool to add this to the bios, but again had no success.

I will try the link you provided tonight to see if the modeline values are the same as returned by gtf.


hilltop*Tech 06-09-2005 06:06 AM

I tried the values for ModeLine returned from the link above. It was again unsuccessful. I also booted to run level 3 - reset the video bios to include a 1280x800 mode and tried again. No good.

I believe that I've tried every suggestion that I have seen on the web. I have included the link below to the X log from the last start which included the modified video bios.

Link to Xorg.0.log

hilltop*Tech 06-10-2005 09:11 AM

With a good night sleep and a fresh cup of coffee, I sat down and decided to tackle this issue again. I decided to use Suse 9.3 Live CD to troubleshoot this problem. This way I can simply reboot to get a clean system and it is the only distro that I've tried that loads the i810 driver correctly. Thanks to Suse and Novell.

I decided to read thru Xorg.0.log and try to understand what it was telling me. If you remember, I used the 915resolution tool to patch the bios of the video chip to include a resolution of 1280x800. But, that appeared to do no good. Well, stepping thu the log file, I noticed that the mode that I patched was not listed in the file. X detected and listed other modes correctly and also listed modes with 0 values. So, I decided to take a mode that was properly detected and change it to the 1280x800 resolution. I also added ModeLine for both the values I received from and gtf.

Voila, after restarting X - I finally have 1280x800 resolution. Its beautiful and crystal clear.

I can now get rid of Windows!

Thanks to everyone for your help.

All times are GMT -5. The time now is 06:40 PM.