LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   X window don't run - Suse 9, red Hat Enterp. 4, etc (https://www.linuxquestions.org/questions/linux-hardware-18/x-window-dont-run-suse-9-red-hat-enterp-4-etc-356806/)

striker7691 08-25-2005 06:10 AM

X window don't run - Suse 9, red Hat Enterp. 4, etc
 
I have a Mitsubishi Diamondtron 17", Asus Gforce FX 5950 and ASUS AX7N8 Deluxe with nvidia chisept

I have no problem with Red Hat 8 or 9, but I tried install Suse 9, Red Hat enterprise Server 4 AS, Fedora and one or two more free distributions modern versions (i can't remember their names at this moment) and ALWAYS I have same problem: the X-windows can't initialize... i have tried to install it whith generic monitor and graphic card, but i see always the same message.

I'm afraid i'm condemned to work with old linux version until i should change my hardware, and i haven't thing about it

Can you help me, please?

Thanks, and sorry for my bad english...

spindles 08-25-2005 09:39 AM

Don't know if I can help, but...
to help you get a useful answer can you tell us:
1. What is the message you get when x won't start?
(Something about 'no screens found' perhaps?)
1. Are you using xorg or xfree86?
If so, have you looked into the config file for it?
(e.g. a file called "XF86Config")
You may be able to locate a log of the problem in
/var/log/xdm.errors.
In any case in somewhere like /var/log (might depend on distribution--I don't know) you might find other messages logged by your X.
For example I have XFree86.0.log.
Anyway, tell us a bit more: with a bit of luck it will be easy to fix.

striker7691 08-26-2005 02:05 AM

Thanks for the help.
Sorry, I don't remember the message exactly (i'm at work, i haven't internet at home) and i have forgotten my notes on my desktop.
Yesterday I probed a solution extracted from Red Hat Knowledge Database,

It may be possible to use the VESA graphics mode to access X.

Boot your system. You should see the GRUB menu appear with a countdown timer. Before the timer expires hit the "e" key. Now you should see three options and one of them (the 2nd one) is the kernel option. Use the down arrow key to select the kernel option and hit the "e" key again. You will now be in edit mode and the cursor will be positioned at the end of the line. Now hit the Spacebar once or twice and append the following:


3 vga=791

Note that there is no space in vga=791. Now hit the "Enter" key and then press the "b" key to boot. You should notice that your fonts are now smaller yet more crisp. This should tell you that your video card supports the kernel framebuffer mode. This would hopefully help us get X to work later. This option also helps for those machines that could not even start a GUI-based installation. Passing the option "linux vga=791" at the installation boot prompt sometimes assists when starting the X server.

The system would now present you with a text-based login prompt. Login as the root user.

The next step is to modify the /etc/X11/XF86Config file. Open this file in an editor of choice:

Look for the line containing:


Section "Module"

and beneath this line:


Load "dri"

Comment out the "dri" module by putting a pound symbol (#) at the beginning of the line as shown below:


#Load "dri"

The next step is to look for a line containing:


Section "Device"

and beneath that:


Driver "abcd"

The text string, "abcd" could be anything. A typical example would be "i810". Yours could be entirely different. You should change the value "abcd" to "vesa" like below:


Driver "vesa"

Save the file and now we test it. Execute the command:


startx

In a few moments the GUI should appear. If not then you might want to review the changes that you have made. Check for errors on the screen to see reasons for the failure.



I have obtained start X windows (FINALLY... :) ) but only at 1024x768, no matter I select at Visualization Panel. I think that the problem is in the general Nvidia driver included at linux distributions and i have dowloaded the latest version. Tonight I'll install the new one. This is the solution? Tomorrow says.

Thanks again.

One more thing: someone have problems with the general drivers of OS for graphics cards?

spindles 08-26-2005 07:11 AM

I would not rush into blaming the nvidia driver too quickly.
XF86Config contains "modelines" which specify the resolution and refresh rate details for different settings. E.g.
Modeline "1024x768_70.00" 76.16 1024 1080 1192 1360 768 769 772 800

As far as I can make out X will usually:
1. come with some default ones (in XF86Config)
2. try to talk to the monitor to establish valid settings
Of course X might not be able to determine all your monitor's capabilities.
To find out more about this you could search LF for "modelines".
Generally the people most concerned about this are trying to get two monitors working to their preferences, but it doesn't hurt to learn about how XF86Config works.

striker7691 08-26-2005 10:02 AM

Thanks, spindles.

Tonight I'll revise the modelines at XF86config (well, in RH enterp 4 it have another name, but no matter) and I'll adjust them , testing before in windos xp. Maybe the problem are in the refresh rates.


Sorry but.... what mean "LF"? :confused:

refdoc 08-26-2005 01:08 PM

One of the simplest solutions for X trouble i have found is to use a Knoppix CD to establish the parameters and simply copy over the XF86Config-4 file. This is largely compatible with xorg.conf and should also work there (and vice-versa)

spindles 08-28-2005 07:18 AM

What means LF?
Means LQ, Linux Questions.
Sorry about the typo.

striker7691 08-29-2005 01:53 AM

Thanks all.

I do it! I have boot in VESA mode, and then I have installed the last driver from nvidia graphics card and reboot. And voilá!! The X windows run without problems, very fast and smooth.... I have spent time and time with reintalations, downloading anothers distributions, reviewing LQ ;) and finally I got.

Thanks again.


All times are GMT -5. The time now is 06:56 AM.