-   Linux - Hardware (
-   -   Wrongly configured X server on Red Hat AS (

parthiv108 06-13-2006 01:23 AM

Wrongly configured X server on Red Hat AS
Hi Everyone,
I am a newbie at Linux and am trying to install Red Hat Advanced Server.
During the installation I was asked to choose a graphic card that my system was using, unfortunately it was not listed in the options, so I just chose one :AGX (generic). Oh well now I can't get any GUI
I tried the "startx" command but it failed to bring up any GUI, I got some fatal error. So How do I reconfigure the X server? The GUI at install time looked beutiful so I can't understand why the system didn't ask me for the default it picked.

On a previous installation attempt I chose the most basic card (Unsupported VGA compatible), this did bring up the GUI but it was horrible.
So having said so much, my question is how do I reconfigure my wrongly configured X system/server?

My machine doesn't have a PCI or AGP card I am using the inbuilt video card that is on the motherboard. It is a MSI motherboard (MS-6524) with SiS chipset (Sis961).

elluva 06-13-2006 03:05 AM

No generic vga does not go further then the vga standard which only covers color depths of 1, 4 and 8 bits. The generic setting for a recent video card is vesa


Section "Device"
        Identifier "devname"
        Driver "vesa"

Just take a look in /etc/xorg.conf and look for the lines with something along to the above. Then just change the Driver option to vesa. Save the file and start you X server. Things should work now. Vesa nearly always works as a default, but most people want to get some more out of there video card (like decent opengl support).

Once it works take a backup copy so you can experiment further in safety ;).

parthiv108 06-15-2006 01:21 AM

doesn't work
I tried doing according to the above post but things didn't work out. I got an error saying the driver was not recognised (vesa).

parthiv108 06-15-2006 01:26 AM

some progress?
I tried the commands you guys suggested but they were not recognised (xorgconfigure). I am using Red hat Advanced server (Pensacola). I even tried redhat-config-<TAB>
There were no options for reconfiguring the x server.
I tried xf86config and it brought up a text menu!
Man, the questions asked were quite difficult cause i wasn't sure about the specs of the card and monitor.

After some ad hoc hacking i managed to get the following error message when did the startx command:
"Configured device found but display modes couldn't be resolved"

A correction on my previous post: the chipset used by the mother board is SiS 645 and NOT SiS961(well the is a Sis 961 chip on the motherboard but it is on the corner and is quite small compared to Sis 645).
How do I find out how much RAM the video card uses?

elluva 06-15-2006 03:21 AM

post the results of the command lspci please. This way we can know what kind of VGA is there, since you haven't mentioned this yet.

Red Hat should have almost the same tools as fedora, then you shouldn't have to edit the xorg.conf manually. Try running the command system-config-display --reconfig. Now you take the vesa option and a conservative setting as default resolution (1024x786 max!).

You should at least be able to get it working this way. Every X server has drivers for vesa, certainly the one shiped with RH.

elluva 06-15-2006 03:22 AM

If the above still didn't work, post the xorg.conf here, without that it is very hard to find out what is wrong!

parthiv108 06-16-2006 02:20 AM

ls pci output
here are the results of my lspci command:
00:00.0 Host bridge: Silicon Integrated Systems [SiS]: Unknown device 0650 (rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] 5591/5592 AGP
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] 85C503/5513
00:02.2 USB Controller: Silicon Integrated Systems [SiS] 7001 (rev 07)
00:02.3 USB Controller: Silicon Integrated Systems [SiS] 7001 (rev 07)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] SiS7012 PCI Audio Accelerator (rev a0)
00:0f.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139 (rev 10)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS]: Unknown device 6325

Here is the version of my Xfree86: 3.3.6a
The version gcc is 2.96

I don't know whether the divers listed at this link will work:

What is the next step?

elluva 06-17-2006 10:54 AM

have you tried system-config-display as I supposed in one of my previous posts? Wait with those drivers until we have your box running with the vesa drivers.

parthiv108 06-18-2006 10:54 AM

there is no such command
there is no such command as system-config-display, there are some rehat-config-<options>, but none for display.
I typed "setup" at the console and got a menu for setting up various devices. When I chose the X-Configuration option, it brought up the X-configorator menu. Here I chose my options for keyboard and mouse, then moved on to graphics card and monitor.

Well incase I havn't made it clear:
I have an onboard video card (as in on the motherboard). The motherboard chipset is SiS 645, but SiS 650 works just as well. The video has 32MB of RAM.
I am using an HP60 monitor that is probed by the system. The probed settings are: Horizontal Sync- 30-50Khz
Vertical Sync- 50-120Khz

I tried using generic settings (Generic SVGA, Generic S3, etc) for the card but still no luck.

I tried using the closest match with SiS chipset (SiS 630, SiS626) but still no luck.

I also tried the unlisted card option.

I can only get the GUI to come up with 8 bits colour and the resolution is worst than 640 X 480. So all the menus and text are so big that you can view them properly.

So the settings I used to get this poor quality GUI are:
VGA card: Unlisted Card
Monitor Settings: Probed settings
Clockchip settings: No clock chip settings (no improvement if changed)
Resolution: 800 X600, 8 bits (doesn't bring this resolution though), no change even if setting is 640X480. System fails to display anything more than 8 bits (which not a big prob..I will make do with 256 colours)

SO is there a way of improving the resolution? At the moment it is very bad I can't even see all the text written to the screen (all the windows and dialog boxes are larger than life!!!)

All times are GMT -5. The time now is 02:03 AM.