Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 11-03-2004, 04:31 PM   #1
LQ Newbie
Registered: Sep 2004
Posts: 14

Rep: Reputation: 0
Writing to FAT32 and reading from NTFS in FC2

My computer has 4 partitions on it; the NTFS partition for WIn2000, the ext3 partition for Fedora Core2, a FAT32 partition for transferring data between the two; and another FAT32 partition (my USB mp3 player). VC2 reads from both vfat partitions fine; how do I set it up to wirte to them? Also, I've heard that it is possible to read NTFS partitions in newer distros. How do I set this up?
Old 11-03-2004, 04:43 PM   #2
Registered: Oct 2003
Location: South London
Distribution: Gentoo.
Posts: 297

Rep: Reputation: 30
NTFS read support needs to be enabled in the kernel - this probabaly means recompiling the kernel. See the numerous howtos all over the place.

Old 11-04-2004, 10:21 AM   #3
LQ Newbie
Registered: Sep 2004
Posts: 14

Original Poster
Rep: Reputation: 0
Right now I'm less worried about NTFS support than FAt32. Ok, I believe I know what the problem is: it's not a question of support, but of permissions (for the vfat HDs). The permissions are set so that only root can write to the drives, however when I change the permissions in the root account it won't save: it says the permissions are changed, but when I log back into my home accoun, it says I'm still not allowed to write to it. Is there a terminal command I can do to change the permissions?
Old 11-04-2004, 12:20 PM   #4
Registered: Apr 2003
Distribution: Fedora Core 4
Posts: 34

Rep: Reputation: 15
For NTFS support i use linux-ntfs which can be downloaded here for FC2

It's an RPM so you won't have to recompile the kernel.
Old 11-04-2004, 04:22 PM   #5
LQ Newbie
Registered: Sep 2004
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks a lot! But is there a command to enable users to write to certain locations? I change the permissions to my fat32 drives in root, but when I log back into another account it says I'm still only allowed to read from them.
Old 11-04-2004, 04:26 PM   #6
LQ Newbie
Registered: Nov 2004
Posts: 2

Rep: Reputation: 0
to read and write to FAT32 add the following line to the bottom of your /etc/fstab (file)
/dev/hda1 /mnt/windowsFAT32 vfat rw,umask=0000,uid=user,gid=group 0 0

change (UID) to the username you want to give permission to and (GID) to the group
as an example this is what it looks like on my computer.

/dev/hdb3 /mnt/SharedDrive vfat rw,umask=0000,uid=neonix,gid=neonix 0 0


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
seeing/reading ntfs/fat32 partitions from linuxFC4 teto Linux - Newbie 12 11-27-2005 12:29 PM
C File reading and writing AbhishekSamuel Programming 3 05-03-2005 04:59 PM
Help reading and writing to file xiste Programming 1 04-15-2005 01:43 AM
Writing to an NTFS volume using captive-ntfs (repairing boot.ini) macskeeball Linux - General 3 02-06-2005 10:28 PM
Mounting and reading NTFS and FAT32 patitions Forezt Linux - Software 10 02-25-2004 02:19 PM > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 07:13 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration