LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   wireless is disabled by hardware switch (http://www.linuxquestions.org/questions/showthread.php?t=4175495521)

phazon 02-19-2014 11:00 AM

wireless is disabled by hardware switch
 
I have SolydX (XFCE?), Ubuntu (Unity, XFCE, LXDE), Mint (Cinnamon, XFCE), and Manjaro (XFCE, for giggles) installed on each of four partitions.

For Ubuntu and Mint, I had to go through some steps to download and install the b43 drivers for the broadcom bcm4311 wireless card that is in my laptop (Dell Inspiron 1501).

SolydX and Manjaro both worked "out of the box", and I did not have to go through any extra steps to have the wireless working.

Now, in ANY/ALL of the distros, when I boot up, I have no wireless, and clicking on the wireless icon gives me the message

"wireless is disabled by hardware switch".

It just so happens that this started happening just after I got some updates for Ubuntu, but since this is happening on all distros, including the non-debian based Manjaro, I don't think that there is any real correlation.

I looked in on some other threads with the similar problem, but they all seem to have been resolved with steps that do not work for me.

I also tried re-booting from a USB live version of SolydX, and the wireless worked. re-booted form hard drive, it worked for a minute, then went off again, same message.

I think I might have a bad card.

In searching for a BCM4311, I also found adds which interchange JC977, and DW1490 with BCM4311 in the same add, as if they are the same card with differing part numbers.

Any idea if these are indeed the exact same part? Would my system recognize it as BCM4311 if I replaced with on that was listed JC977 or DW1490 in the add? Would my system still use the b43 driver?

Questions, questions....
Is there a terminal command that I can use that turns on (enables) the wireless? Any other suggestions?


Thanks in advance.

pingu 02-19-2014 01:31 PM

Laptops have a "on/off switch" to enable/disable nwireless - this could be a manual (physical) switch or keyboard controlled.

My guess is you have a wl-switch that is controlled by keyboard, some distros have drivers for it some don't. This switch is often something like "Fn + F5".
Now an update could cause this switc to start functioning - maybe earlier no driver for it was included but now it is?
Wl suddenly going down *could* be caused by you accidentally pressing those keys.

But then, it could also be a faulty card. Could also be unreliable driver.
But start with checking what keyboard combination is used to control wl.

phazon 02-19-2014 05:31 PM

Yeah, this keyboard has the symbol for an old-time radio tower printed in blue on the F2 key, meaning that Fn+F2 should turn it on and off....pushing this combo does nothing.

The wireless is decidedly intermittent.

I believe that it is a bad card.

I am going to replace it.

My system lists my wireless card as bcm4311.

Now I am just wanting to make sure that the BCM4311, JC977, and DW1490parts I am seeing interchanged on line are indeed the same part.

pingu 02-20-2014 01:30 AM

I have a bcm4313, I remember I had to fiddle a bit to get it to function properly.
My drivers are: bcma, bcma-pci-bridge. I could not use the drivers included with Mint or Ubuntu.

phazon 03-03-2014 06:56 AM

update -

It was a bad wireless card. I replaced with a refurbishd one off ebay and it works like a charm, no issues. SolydX and Manjaro, came with the bcm4311 driver "out of the box" while with Ubuntu and Mint, I had to go through some tweaks to download and install the driver. They all work now. The little radio tower (FN+F2) works to turn it on and off too.


All times are GMT -5. The time now is 06:47 AM.