LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Wireless card won't turn on: ipw2200 & rf_kill = 2 (http://www.linuxquestions.org/questions/showthread.php?t=775106)

weakdor 12-12-2009 02:34 AM

Wireless card won't turn on: ipw2200 & rf_kill = 2
 
Hello all, long time reader first time poster.

My old vaio recently died, so I received a handmedown laptop (the brand is PCLaptops, a company that exists in utah). I installed debian stretch on it, and everything is working well except for the wireless card, which will not connect to the wireless network.


After running ifup eth1, my computer will not connect to the network. Running iwconfig gives:
Quote:

eth1 radio off ESSID:"stuff"
So the wireless card is powered off.

catting the file /sys/bus/pci/drivers/ipw2200/*/rf_kill gives an output of "2", which according to the ipw2200 readme means:

Quote:

2 = HW based RF kill active (radio off)
so somehow my wireless card is powered off, and this isn't controlled by the software.

I'm not really sure how to try to fix this, there seem to have been many threads involving similar problems, but the solutions for them have not worked for me. There is an external switch on my laptop which can turn the card on or off. Currently this switch is set to on, but the problem still exists with the switch set to off. I have tried unloading and reloading the ipw2200 module, with no effect. I checked the BIOS, but there is no setting to change the wireless card.

I can confirm the wireless card works with windows on this laptop.


Information about my system which may or may not be useful:

Running Debian/Squeeze.
Quote:

Originally Posted by uname -r
2.6.30-2-686

Quote:

Originally Posted by lspci
01:02.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)

ipw2200 version: 1.2.2kmprq

firmware-ipw2x00 version: 0.18
(corresponds to firmware version 3.0 for Intel Pro Wireless 2200)

possibly useful dmesg output:
Quote:

ipw2200 0000:01:02.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200 0000:01:02.0: firmware: requesting ipw2200-bss.fw
ipw2200: Radio Frequency Kill Switch is On:
Kill switch must be turned off for wireless networking to work.
ipw2200: Detected geography ZZM (11 902.11bg channels, 0 802.11a channels)
possibly useful syslog output:
Quote:

Dec 11 20:55:29 baraddur NetworkManager: <info> Found radio killswitch /org/freedesktop/Hal/devices/ipw_wlan_switch
Dec 11 20:55:29 baraddur NetworkManager: <info> (eth1): driver supports SSID scans (scan_capa 0x21).
Dec 11 20:55:29 baraddur NetworkManager: <info> (eth1): new 802.11 WiFi device (driver: 'ipw2200')
Dec 11 20:55:29 baraddur NetworkManager: <info> (eth1): eported as /org/freedesktop/Hal/devices/net_00_02_3f_08_d6_94
Dec 11 20:55:29 baraddur NetworkManager: <info> (ttyS1): ignoring due to lack of mobile broadband capabilities
Dec 11 20:55:29 baraddur NetworkManager: <info> Trying to start supplicant...
Dec 11 20:55:29 baraddur NetworkManager: <info> Trying to start the system settings daemon...
Dec 11 20:55:29 baraddur NetworkManager: <info> Wireless now disabled by radio killswitch

Thanks in advance for your help. If you need any more info, just give a holler.


Edit:

further digging, i ran the command nm-tool, which gave the following output.

Quote:

-Device: eth1 -----------------------------------
Type: 802.11 WiFi
Driver: ipw2200
State: unmanaged
Default: no
HW Address: 00:00:00:00:00:00
So the address is all 0's. That seems very odd. So is the mac address all 0's because the wireless card won't turn on? or will the wireless card not turn on because some software doesn't know the proper address of my card?

Davno 12-13-2009 04:11 AM

Code:

There is an external switch on my laptop which can turn the card on or off.
Was that kill switch on or off when you printed the output of dmesg
Code:

ipw2200: Radio Frequency Kill Switch is On:
Kill switch must be turned off for wireless networking to work.

and in your syslog
Code:

Dec 11 20:55:29 baraddur NetworkManager: <info> Trying to start supplicant...
Dec 11 20:55:29 baraddur NetworkManager: <info> Trying to start the system settings daemon...
Dec 11 20:55:29 baraddur NetworkManager: <info> Wireless now disabled by radio killswitch

If so you should post again the result with the switch off to see if there is a difference.
On my Debian Lenny i had a problem with the network manager, and i found (google) to uninstall that manager and to config manually wich solved the problem.

weakdor 12-13-2009 11:35 PM

Hey davno, thank you for the response.

My output of dmesg was for when the switch was set to the 'on' position (with windows this meant the card was on).

Changing the switch to off and restarting the computer gave the same output for dmesg and syslog.

uninstalling network manager (via apt-get purge network-manager) also gave the same output for dmesg.

Maybe i should try using a different driver for my intel 2200 card?

Davno 12-14-2009 04:59 AM

Quote:

Originally Posted by weakdor (Post 3790423)
Hey davno, thank you for the response.

My output of dmesg was for when the switch was set to the 'on' position (with windows this meant the card was on).

Changing the switch to off and restarting the computer gave the same output for dmesg and syslog.

uninstalling network manager (via apt-get purge network-manager) also gave the same output for dmesg.

Maybe i should try using a different driver for my intel 2200 card?

Sorry, since your dmesg is the same i don't know where to look after that, wireless is still the biggest problem people seem to have with linux. It sometimes take a lot a googling to find a solution. Don't give up on Debian cause i think its one of the best Linux distro. May be somebody here could help you? Bump!

weakdor 12-14-2009 07:31 PM

I am now fairly convinced there was some software running on windows to turn the card on or off.

Some more nosing around led me to find the program rfswitch. Using some of the commands listed in the README, I was led to believe that the kernel module pbe5 might actually help me. So, I compiled and installed the module. However, this did nothing.

Nosing around a bit more, I found some people who claimed that if they started their laptop in windows, enabled the wireless card, then restarted into linux, the card would be enabled.



So, I tried reformatting my computer and reinstalling windows. I installed the intel wireless drivers. Unfortunately, I'm now having the same problem in windows. Windows can see the card, and correctly install the drivers, but the intel drivers inform me that the wireless card is switched off, and that I should switch it on.

SO, here's what I think happened.

I think my computer was using another driver to control the power settings. So the last time i used the computer, i must have had the wireless card switched to off when my computer was last shut off while running windows.

So somehow I have to contact my laptops manufacturer to track down what drivers they used, and then install those and see if i can switch my wireless card to on.


or i could just replace the card.


Anyways, thanks for all your help.

Brains 12-15-2009 03:51 AM

I've never had problems with my IPW2200, I typically compile my own driver and modify the code to jack up the TX power by 50% if for some reason I "might" need to connect to a wireless network from half a block away when in a pinch..."not that it happens often or anything".

Trouble is for most folks is that they don't know that this wireless device requires one to install the firmware separately as outlined in this article. The non-modified driver/module is included with the Linux kernel, no need to build your own if you're linking to a typical AP. Just install the firmware, reboot, and your card is ready.

maxim-l 11-20-2012 11:01 PM

The following should fix it:

Code:

#rfkill list
#rfkill unblock all

(Install 'rfkill' first).

-- I know long time has passed since you asked, but hope this will help other people.


All times are GMT -5. The time now is 11:47 PM.