LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 06-21-2003, 09:11 AM   #1
J-Dubs
LQ Newbie
 
Registered: Jun 2003
Location: Indiana
Distribution: Slackware 9.1
Posts: 7

Rep: Reputation: 0
Winmodem/Red Hat 9


I'm very new to Linux and I'm having a ton of trouble trying to get my Winmodem installed. I've looked through the forum. I've downloaded the drivers and installed them. I've tried using Kppp to connect, but when I query the modem, it gives me "Modem is busy." Anyone that can offer any help would be GREATLY appreciated. If you need more details ask.
 
Old 06-21-2003, 04:45 PM   #2
qanopus
Senior Member
 
Registered: Jul 2002
Location: New York
Distribution: Slackware
Posts: 1,358

Rep: Reputation: 45
Hello there.
One thing you have to learn is that you can get a lot of info on the web regarding error messages. Just type your error message in google/linux and see what you come up with.
For instance, I typed in "Modem is busy error message" and immediatly, I got some interesting results. Here is what I found:

Modem is busy:

Quote:
What this means depends on what program sent it. The modem could actually be in use (busy). Another cause reported for the SuSE distribution is that there may be two serial drivers present instead of one. One driver was built into the kernel and the second was a module.
In kppp, this message is sent when an attempt to get/set the serial port "stty" parameters fails. (It's similar to the "Input/output error" one may get when trying to use "stty -F /dev/ttySx"). To get a few of these stty parameters, the true address of the port must be known to the driver. So the driver may have the wrong address. The setserial" command will display what the driver thinks but it's likely wrong in this case. So what the "modem busy" really means is that the serial port (and the modem) can't be found.
If you have a pci modem, then use one of these commands: lspci, or cat /proc/pci, or dmesg to find the correct address and irq of the modem's serial port. Then check to see if "setserial" shows the same thing. If not, you need to run a script at boot-time which contains a setserial command that will tell the driver the correct address and irq. The reason that the driver has it wrong may be due to failure of the kernel to understand the lspci data correctly. You might notice this in a boot-time message.
So in short, the dial program isn't sending it signals to the right device because of some mis configurations
Do "cat /proc/pci" and "setserial -a /dev/ttySx" for me in the console, and lets see what comes up. Here, instead of 'x' insert the number of the port the modem is inserted in. For example, if under dos/windows you see the modem is in com1, thats /dev/ttyS0 in linux. You have to be root to be able to do this.

Last edited by qanopus; 06-21-2003 at 05:02 PM.
 
Old 06-22-2003, 04:12 PM   #3
J-Dubs
LQ Newbie
 
Registered: Jun 2003
Location: Indiana
Distribution: Slackware 9.1
Posts: 7

Original Poster
Rep: Reputation: 0
Results:
[root@localhost root]# cat /proc/pci
PCI devices found:
Bus 0, device 0, function 0:
Host bridge: Silicon Integrated Systems [SiS] 645DX Host (rev 0).
Master Capable. Latency=32.
Non-prefetchable 32 bit memory at 0xe8000000 [0xebffffff].
Bus 0, device 1, function 0:
PCI bridge: Silicon Integrated Systems [SiS] 5591/5592 AGP (rev 0).
Master Capable. No bursts. Min Gnt=8.
Bus 0, device 2, function 0:
ISA bridge: Silicon Integrated Systems [SiS] SiS961 [MuTIOL Media IO] (rev 1
6).
Bus 0, device 2, function 2:
USB Controller: Silicon Integrated Systems [SiS] 7001 (rev 7).
IRQ 5.
Master Capable. Latency=32. Max Lat=80.
Non-prefetchable 32 bit memory at 0xe6800000 [0xe6800fff].
Bus 0, device 2, function 3:
USB Controller: Silicon Integrated Systems [SiS] 7001 (#2) (rev 7).
IRQ 9.
Master Capable. Latency=32. Max Lat=80.
Non-prefetchable 32 bit memory at 0xe6000000 [0xe6000fff].
Bus 0, device 2, function 5:
IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 208).
Master Capable. Latency=32.
I/O at 0xd800 [0xd80f].
Bus 0, device 3, function 0:
Ethernet controller: Silicon Integrated Systems [SiS] SiS900 10/100 Ethernet
(rev 144).
Master Capable. Latency=32. Min Gnt=52.Max Lat=11.
I/O at 0xb000 [0xb0ff].
Non-prefetchable 32 bit memory at 0xe5800000 [0xe5800fff].
Bus 0, device 5, function 0:
Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 16).
Master Capable. Latency=32. Min Gnt=2.Max Lat=24.
I/O at 0xa800 [0xa8ff].
Bus 0, device 12, function 0:
Communication controller: Conexant HSF 56k HSFi Modem (rev 1).
Master Capable. Latency=32.
Non-prefetchable 32 bit memory at 0xe5000000 [0xe500ffff].
I/O at 0xa400 [0xa407].
Bus 1, device 0, function 0:
VGA compatible controller: nVidia Corporation NV20 [GeForce3 Ti500] (rev 163
).
IRQ 11.
Master Capable. Latency=64. Min Gnt=5.Max Lat=1.
Non-prefetchable 32 bit memory at 0xe7000000 [0xe7ffffff].
Prefetchable 32 bit memory at 0xf0000000 [0xf7ffffff].
Prefetchable 32 bit memory at 0xef800000 [0xef87ffff].
[root@localhost root]# setserial -a /dev/ttyS2
/dev/ttyS2, Line 2, UART: unknown, Port: 0x03e8, IRQ: 4
Baud_base: 115200, close_delay: 50, divisor: 0
closing_wait: 3000
Flags: spd_normal skip_test
 
Old 06-22-2003, 05:11 PM   #4
qanopus
Senior Member
 
Registered: Jul 2002
Location: New York
Distribution: Slackware
Posts: 1,358

Rep: Reputation: 45
Okey, as you can see, this is the section that covers your modem:

Bus 0, device 12, function 0:
Communication controller: Conexant HSF 56k HSFi Modem (rev 1).
Master Capable. Latency=32.
Non-prefetchable 32 bit memory at 0xe5000000 [0xe500ffff].
I/O at 0xa400 [0xa407].

It doesn't say at what IRQ the device is at. So lets hope it's 4. Try issuing this command:

setserial ttyS2 uart 16550A irq 4 port 0xa400

And don't forget to make the link /dev/modem to /dev/ttyS2, if that's not done alraidy. Now try dailing out. If it works, we will have to write a simple script that sets the serial port right every time you boot up. But lets fist see if it works.
 
Old 06-22-2003, 09:34 PM   #5
J-Dubs
LQ Newbie
 
Registered: Jun 2003
Location: Indiana
Distribution: Slackware 9.1
Posts: 7

Original Poster
Rep: Reputation: 0
Results:
[root@localhost root]# setserial ttyS2 uart 16550A irq 4 0xa400
ttyS2 No Such file or directory
You have new mail in /var/spool/mail/root

Last edited by J-Dubs; 06-22-2003 at 09:54 PM.
 
Old 06-23-2003, 12:10 AM   #6
qanopus
Senior Member
 
Registered: Jul 2002
Location: New York
Distribution: Slackware
Posts: 1,358

Rep: Reputation: 45
Ho sorry, do

setserial /dev/ttyS2 uart 16550A irq 4 0xa400
 
Old 06-23-2003, 12:32 AM   #7
J-Dubs
LQ Newbie
 
Registered: Jun 2003
Location: Indiana
Distribution: Slackware 9.1
Posts: 7

Original Poster
Rep: Reputation: 0
Invalid Flag: 0xa400
 
Old 06-23-2003, 03:00 AM   #8
qanopus
Senior Member
 
Registered: Jul 2002
Location: New York
Distribution: Slackware
Posts: 1,358

Rep: Reputation: 45
God man, i'm scruing up here big time. This is that it should be

setserial /dev/ttyS2 uart 16550A irq 4 port 0xa400

I'm so sorry for this.
 
Old 06-23-2003, 05:05 AM   #9
juby
Member
 
Registered: Dec 2002
Location: Bangalore, India
Distribution: Ubuntu 5.*
Posts: 241

Rep: Reputation: 30
u have the drivers for Connexant winmodems @ mbsi.ca or linuxant.com
 
Old 06-23-2003, 08:49 AM   #10
J-Dubs
LQ Newbie
 
Registered: Jun 2003
Location: Indiana
Distribution: Slackware 9.1
Posts: 7

Original Poster
Rep: Reputation: 0
ok i tried what you told me to type....no results....just went to a new blank line (maybe that means it worked?)....but when i tried to query the modem...same result "modem is busy"

and yes juby i have the drivers from linuxant.com
 
Old 06-23-2003, 09:36 AM   #11
qanopus
Senior Member
 
Registered: Jul 2002
Location: New York
Distribution: Slackware
Posts: 1,358

Rep: Reputation: 45
Hmmm, I'm baning my head here. Are you sure /dev/ttyS2 is where your modem is at? Also, what you can do is check your configuration in windows (if you haven't thrown that out yet). Check at what com port the modem is and what the IRQ and IO values are.
I didn't think it will work, but you can try another dialout prog. to make sure it's not a kppp problem. You can use wvdial.
And to make clear, after you issue the "setserial" command, it should go to a blank new line. That indeed means it worked (or atleast that part) .
I will check-out the net some more, see if I can find somthing.
 
Old 06-23-2003, 09:47 AM   #12
qanopus
Senior Member
 
Registered: Jul 2002
Location: New York
Distribution: Slackware
Posts: 1,358

Rep: Reputation: 45
Okey, what a minute, tell me step by step what you did to install the drivers of that babey. You have read the readme didn't you. Did you run "hsfconfig". If not, do so.
On the linuxant.com site, I see the modem is adressed as "/dev/ttySHSF0" and not "/dev/ttySx", so that's the fist thing we did wrong.
There should be a symbolic link /dev/modem. Do a "ls -al /dev/modem" to see what the symlink is pointing at.

Last edited by qanopus; 06-23-2003 at 09:49 AM.
 
Old 06-23-2003, 12:18 PM   #13
J-Dubs
LQ Newbie
 
Registered: Jun 2003
Location: Indiana
Distribution: Slackware 9.1
Posts: 7

Original Poster
Rep: Reputation: 0
i'll just run the install over....how do i uninstall the drivers?
 
Old 06-24-2003, 12:49 AM   #14
juby
Member
 
Registered: Dec 2002
Location: Bangalore, India
Distribution: Ubuntu 5.*
Posts: 241

Rep: Reputation: 30
I think u r not doing the right thing by setting the port to ttyS.. if i remember it was something like /dev/ttyHS15 or somethying like that

to uninstall the drivers if u used the rpm

type
rpm -e <package name>

or if u compiled an d installed it use

make clean

visit mbsi.ca . i tried the drivers from that site

after intalling the drivers, just set the device to /dev/ttyHS* in the device tab of kppp... no big fuss other than that

u can test the drivers u installed using minicom

type

minicom -s
and set teh serial port to /dev/ttyHS*

and then type
ati
ati2
ati 3
ati 4


u should get some responses from the modem
(consult the readme / install file o nwhat the device name is to be set to /dev/ttyHS* )

another problem may be that u havent identifed ur chip properly
there are 2 types hcf & hsf and both have differnet versions of drivers.. chk that too

connexant modems are the easiset to work on linux from my experience ..dont lose heart linux is worth the effort
 
Old 06-24-2003, 11:56 AM   #15
J-Dubs
LQ Newbie
 
Registered: Jun 2003
Location: Indiana
Distribution: Slackware 9.1
Posts: 7

Original Poster
Rep: Reputation: 0
it wouldn't let me uninstall the package it says "package "hsflinmodem.... not installed", but when i try to install the file it says "file is already installed"
i played around with it some this morning and i got it to query the modem (the device i used was /dev/ttyS1, and it worked)
i know for sure that it's an hsf modem....and there is no /dev/ttyHS* in the dev folder...so that makes me think the install of the drivers didn't complete correctly...am i right?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I need a driver for agere winmodem, red hat 8 josuebarreto Red Hat 1 01-08-2005 06:06 PM
Lucent Winmodem & Lexmark X73 on Red Hat 9 nemesisza Linux - Hardware 1 06-22-2003 10:28 PM
winmodem in red hat 9 KoBe1510 Linux - Hardware 4 06-06-2003 08:05 PM
winmodem help in red hat 8 redhatlinuxman Linux - Hardware 2 03-29-2003 06:34 AM
Red hat linux 7.1 doest not detect my modem, says its a "winmodem" linux2cool Linux - Newbie 3 10-17-2001 01:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration