-   Linux - Hardware (
-   -   wifi driver installed, but not working on Ubuntu Gutsy (

gvp87 02-03-2008 11:20 PM

wifi driver installed, but not working on Ubuntu Gutsy
I just installed the driver for my Broadcom mini-pci wifi card, using Ubuntu's Restricted Drivers' installation. According to my system, my wifi card is up and running, but I still can't connect. I don't get why...

the light on my computer showing the wifi access is now working (it never did before)
I entered in my essid and wep key into ubuntu's network Settings manager, and I set the wireless capability to active.

I even tried using the command "sudo dhclient eth1" and it still can't connect. eth1 is my wireless interface.

I can't figure out what's wrong. What am I missing?


b0uncer 02-04-2008 05:26 AM

First test:

sudo iwlist eth1 scan
Does this produce scan results? It should. If you find your network there, pick up the ESSID.

Second: If the AP only uses weak WEP encryption, (WPA would be a lot better), you can test the connection easily with iwconfig. Like this:


sudo iwconfig eth1 essid "network_essid_here" key s:ascii_password_here
If you instead use hex password (not ascii), use 'key hex_password_here' instead of 'key s:ascii_password_here' (leave s: off).

That should get you connected - the only point you can type wrong there is the password (use s: if it's in ASCII like it usually is, and don't use it if you have a hex password; if you want to make sure, use quotes around the password too). If it succeeded,

sudo dhcpcd eth1
should give you an IP within a moment, and then you should be online. If the iwconfig command tells you there is no such interface, try running 'ifconfig eth1 up' first to bring the interface up.

If you use WPA encryption instead, like you should, you need to setup wpa_supplicant OR use NetworkManager (the graphical thing). NetworkManager is easier - just point, click and type password - but wpa_supplicant isn't that difficult either.

If iwlist eth1 scan brings scan results, driver and hardware are working fine. If it doesn't, check the driver. If scanning works but connecting doesn't, it's very probably a problem in the encryption key; WEP encryption should be supported by all wireless hardware (WEP too nowadays, though) and Linux wifi drivers, so that ought not be a problem. Of course you can try without encryption first if you like; turn off all encryption from the access point (note: this is both foolish and dangerous, so don't leave it like that for long!), then just run

sudo iwconfig eth1 essid "network_essid_here"
sudo dhcpcd eth1

and see if it works. If not, there is something seriously wrong with your configuration or driver. If it works, turn on encryption and try to connect with the right key (iwconfig for WEP keys or no encryption, wpa_supplicant for WPA encryption, or NetworkManager in either case).

gvp87 02-05-2008 04:18 PM

okay, so I did the "iwconfig" command with my essid and my key. I did the "dhcpcd" command after, and I got the output "Error, eth1: timed out."

So i did the "ifconfig eth1 up" and then did the 'iwconfig', but still nothing.

But I am getting scan results, so that's good.

Also, just before running all these commands, i unplugged my network cable to test out the wifi, but after running all these, I couldn't connect back with a wired connection. Usually when I plug in my cable, the lights the port on my computer turn on, but those aren't even lit.

I did 'sudo ifdown eth0' to reset the interface, then i did 'sudo ifup eth0' and it output 'no DHCPOFFERS received'.

I'm on another computer right now, bc I can't use wired or wireless connection!! lol

I didn't think any of those commands that I ran wouldn've changed any eth0 settings. How can I get them both up and running?


gvp87 02-05-2008 04:42 PM

I figured it out.

I can't get the wired connection back up, but i got the wireless connection to run.

Just for fun, i typed in "iwconfig", and noticed in the output, that there was no ESSID or KEY(the entries next to them said 'any'), which I thought was strange, since i had just entered it in with a previous command to iwconfig.

i typed in 'iwconfig eth1 essid "essid" '

i checked iwconfig, and my essid was there!

I did it again with my key, and it worked.

I used your dhcpcd command, and iwas connected!

All times are GMT -5. The time now is 03:04 AM.