-   Linux - Hardware (
-   -   Wifi card Atheros a+g (

Stabby McTwist 10-18-2006 02:44 PM

Wifi card Atheros a+g
I've got this wifi card, it has Linksys stamped all over it but it's an Atheros chipset. Well, it suddenly disappeared. I've tried 3 different distros with it, and I know it isn't a driver issue. It just plain doesn't show up. The little light on the card blinks to say it has power, but nothing I've installed will tell me it even exists. Not even an unkown hardware slot or anything. It IS connected properly and it IS in working order as far as I know. So far I've tried it with Kubuntu 6.06, Mandriva 2006, and SuSE 10.1. SuSE is still on it. I've tried moving it to a different port, but that didn't work either. It's a PCI card, and my other PCI card (a USB expansion card) is detected and works perfectly. I'm not really experienced with Linux yet, so this could be something absurdly simple.

mimithebrain 10-19-2006 06:03 PM

Does it show up in lspci?
Do you have an IRQ conflict?
Is Madwifi loaded?

Stabby McTwist 10-24-2006 03:17 PM


andrew@Kaji:~> lspci
bash: lspci: command not found

I tried that with i, I, l, L and they all got the same thing.

I don't know what an IRQ conflict is.
Madwifi IS installed, and was previously. You might note that absolutely everything save for my own eyes and the little power light on the card says that that particular slot is empty.

Thanks for your help.

EDIT: I went to the PCI Device Drivers module of YAST. It detects it as "Linksys AR5212 802.11 abg NIC" and apparently doesn't have a driver for it. There's two options: Driver and SysFS Directory. Would those help anything?

farslayer 10-24-2006 08:35 PM

Well for Debian based Distros (Kubuntu) how did you install the driver ? did you use the Module-assistant ? Drop dead easy to get the Atheros cards working using Debians module-assistant method.. I watched someone struggle for over an hour trying to manually compile this driver in Debian. I finally got him to stop and try this method and his card was working in under 2 minutes...

apt-get update
apt-get install module-assistant madwifi-source madwifi-tools
m-a prepare
m-a a-i madwifi

modprobe ath_pci

tail -n 30 /var/log/demsg

the tail of dmesg should show you the card loading..

Best of luck !!

mimithebrain 10-24-2006 10:10 PM

I have a debian based system (ubuntu), I still tought it was quite easy to install the driver manually. I had to install build-essentials, and a few other utilities, uninstall restricted drivers, but then it works like a charm :D

Stabby McTwist 10-29-2006 11:20 PM

Ok, I borked my SuSE by playing around with it too much, heh. I switched back to Kubuntu and now it works... Well, sort of. It won't just plain start up, I have to connect it myself, and it takes a long time to get the ip

All times are GMT -5. The time now is 04:46 AM.