-   Linux - Hardware (
-   -   WiFi adapter complication (

dingle959 03-23-2007 07:10 PM

WiFi adapter complication
I have installed a D-Link WDA2320 into my Mandriva 2006 and it worked fine. After a week or two I rebooted the system and it does not recognise the NIC at all. Nothing in the boot up script about ath0. I Booted up Mandriva One USB and it worked fine.
Why will it not recognise the NIC now in the Mandriva 2006 s/ware?
The Control Panel/Hardware lists it as unknown ath0_PCI and when I try and configure it says that no unit of that name can be found - no drivers will access it.
iwconfig does not list it.
Frustration is setting in!
Any help?

Cereal765 03-23-2007 10:53 PM

I assume "ath" is referring to the chipset of the card in question (atheros). I know two things that are troublesome with an atheros card:

1. You can use "madwifi" with it and it will work.
2. You can use the native kernel driver for atheros cards and it will work

The Problem? If you use one and try and use the other, it will NOT work. I don't know anything about mandriva, but I'm willing to bet that it came packed with madwifi, and now the native kernel driver is trying to take over because you ran some kinda system config and thats what it chose to do.

My advice is to de-install, and then re-install madwifi (if indeed you do have it, im almost positive you do) and tell it to use your card. Whatever crazy auto-config thing mandriva has, DO NOT TOUCH IT, because it will try and config for the native driver, which will make mr.card not work again. I hope this helps you!

dingle959 03-24-2007 08:57 PM

D-Link WiFi adapter error
Hi Cereal,
Thanks for the posting.
I did as you suggested and removed madwifi (it is a part of Mandriva 2006 installation). I rebooted and before I reinstalled I went to the Control Panel and did a Wireless installation. I received the same error comment 'no such device' as I did before. I then installed madwifi but received no request for the driver to use, it just loaded and I got the same error again when I tries to load the Wireless setup.
It seems that the NIC (D-Link WDA2320) is not being recognised at all. After I had removed madwifi the reboot still didn't find the ath0 as it loaded.
Should I have unloaded and reinstalled using the CLI? I'n not too familiar with those commands and if you think it might help I would like you to give me them.
Once again, many thanks for your help.

Cereal765 03-25-2007 04:27 PM

The problem seems to be deeper than I initially thought. I re-read your first post and saw that you said the card was not being recognized AT ALL, which worries me. If there was a driver conflict like I was thinking it would have shown up and not worked.

My question is, do the lights on the ACTUAL card come on and everything? I ask because sometimes my card (under ndiswrapper [your card will not work with ndiswrapper]) will blank out, as in, the lights will just turn off and I'll no longer be able to see it in iwconfig and will exprience problems shockingly similar to what your describing. To fix this, I usually unplug the card, plug it into a new port, unmount it, restart the computer and usually the lights will come shining back on and everything will work.

What scares me, is that your card is a PCI card (correct me if im wrong), and so if the card indeed is not being powered, its a much more serious issue.

All times are GMT -5. The time now is 03:19 AM.