-   Linux - Hardware (
-   -   When empty, cannot open cd/dvd door with button or command line. (

chuckbuhler 05-17-2009 02:55 PM

When empty, cannot open cd/dvd door with button or command line.
I have two internal DVD drives, one a DVD/CDRW and the other a DVDRW, plus an external USB DVDRW.

The external DVDRW works perfectly. The two internal DVDs will not open by button, or using the eject command if there isn't something already in them. The both burn disks just fine and read disks just fine. I haven't tried playing an audio cd, but would assume that should work too.

The computer is:
DakTech Discovery 6
Intel D946GZ - Dual core 3.4ghz
4gb Ram - 330gb sata dasd

DVD 0 /dev/sr0
Lite-On DVD C LH52C1P

DVD 1 /dev/sr1
Lite-On DVDRW LH-20A1H

DVD 2 /dev/sr2
Sony DVD RW DRU-820A

DVD 0 and 1 are hooked up to a single IDE cable.

I'm running openSuse 11.0 with current updates. Desktop is KDE 3.5.?. K3B burns disks on all three drives with no problems. When K3B is done burning a disk, it can open the drives OK.

(DVD 0 and DVD 1)
If I use a paperclip, open the drives, and put a disk in there, I can umount and/or eject just fine, as long as a disk is in there. Remove the disk and close the door then cannot open the drives.

(DVD 2)
The external drive works perfectly with or without a disk.

I've tailed the /var/log/messages file and don't see any errors. Dmesg doesn't show any errors.

sudo as root:
dhcppc1: # eject -rv /dev/sr1
eject: device name is `/dev/sr1'
eject: expanded name is `/dev/sr1'
eject: `/dev/sr1' is not mounted
eject: `/dev/sr1' is not a mount point
eject: `/dev/sr1' is not a multipartition device
eject: trying to eject `/dev/sr1' using CD-ROM eject command
eject: CD-ROM eject command failed
eject: unable to eject, last error: Input/output error

I get the same thing for both DVD 0 and DVD 1. The command works on DVD 2 with or without a disk present.

A Google search hasn't turned up any real help on this so far.

Any suggestions where to look next would be helpful.


Simon Bridge 05-18-2009 02:05 AM

Possibly something is "using" it. clean up with:

fuser -k -i /dev/sr1

eject -rv /dev/sr1

Did you try with sudo?

chuckbuhler 05-18-2009 06:36 AM


Originally Posted by Simon Bridge (Post 3544268)
Possibly something is "using" it. clean up with:

fuser -k -i /dev/sr1

eject -rv /dev/sr1

Did you try with sudo?

Nothing is using it. Have done the fuser step.

That is the eject command that I've been using, as sudo, and as root.

I've also tried this after a fresh boot of the computer, logging in as root, and trying to eject before running anything else except konsole.

I've noticed that hald is set to check the drives every two seconds. I've tried restarting hald, but that didn't make any difference.

The real oddity to me is that if there's a disk in the drive, the button on the front works without haveing to do a manual umount, it automaticly does the umount and eject. If no disk in the drive, the light flashes a couple of times, but the drive does not open.

Simon Bridge 05-18-2009 09:33 AM

what do the logs say after you try to eject?

chuckbuhler 05-18-2009 12:47 PM

I'm not at home to double check right now, but from the origional post, I don't see anything in /var/log/messages or from dmesg. I've also cleared dmesg and tried again, with the same "nothing there" results.

Is there another place I should be looking?

I've also tried useing /dev/cdrom, /dev/dvd, /var/dvdrw, etc all with the same results as using the /dev/sr0 or /dev/sr1.

I'm going to try removing one drive tonight and see if it's an issue with two drives on the same IDE cable. I've already made sure that one is set to master and one to slave.

thank you for your quick responses. Any help is greatly appreciated. Been fighting this for quite some time. I'm beginnig to think I've skipped something very simple and obvious, so the second set of eyes on the problem is really helpfull.

cgtueno 05-18-2009 11:55 PM


May I ask a really innocent question ?

You wrote "DVD 0 and 1 are hooked up to a single IDE cable"

I take it that they are both connected to the SECONDARY IDE channel
with the drives configured as master and slave ?

Have you checked the configuration in the systems BIOS menus to see that the configuration looks exactly as expected ?

Can you identify and post the make and model of the motherboard.

Interesting problem.


cgtueno 05-19-2009 12:12 AM


I've just had a couple of thoughts about this.

Can I suggest that you:

(a) Try booting the system with a live Distro (Ubuntu, etc) and see if the problem is repeatable.

(b) Replace the slave CDRW drive with a CDROM and see if the problem persists.
Surfing the www with google has turned up an number of references to people having problems with two CDRW devices (master and slave) on the same IDE channel, which was eliminated by changing the secondary to a CDROM. Sounds like a CDRW compatibility problem though I'm scratching my head as to why that should be the case since the devices are addressed by the system independently as master and slave on the IDE channel.

Still might be worth a whirl.

Most interested to hear how you get on.



lazlow 05-19-2009 01:28 AM

I have seen this when the drives are setup as cable select, rather than master and slave.

chuckbuhler 05-19-2009 07:59 AM

Thanks for all the responses. I didn't get the chance to mess with it last night, played with the grand kiddos instead. (Funny how those little farts tend to out rank nearly everything)

There is only one IDE port on the computer so only one cable possible. They are set master and slave. The hard drives are SATA.

I intend to remove the DVD 0 device and go with just the DVD 1 device as it does more thant the other one does. I don't duplicate disks, just that the computer came with the first drive and I wanted the second one.

I'll re-post on here what I find out.

cgtueno 05-19-2009 07:35 PM


Cool. I never set up devices with cable select, always choosing to set them as master and slave.
I hope that doesn't reveal anything sinister about my subconscious personality - Roars with laughter and promptly falls off his chair !

As a matter of interest, Lazlow, when you observed this type of fault were the drives LG or made by the same manufacturer ?



lazlow 05-19-2009 07:49 PM

It seems to be more of a motherboard chipset issue rather than a drive issue. Off hand I do not remember what motherboards that had the issue. Probably it would have been late PIII early P4 days.

chuckbuhler 05-19-2009 10:45 PM

I remove the first drive (DVD 0) and switched the DVD 1 drive to master. DVD 0 is not plugged in or powered.

Same issue. With no disk in the drive, the front button does not work and cannot eject using the eject command.

Tried booting the computer with a Knoppix disk and had the exact same problem.

Answer to questions above:

This is in the primary IDE slot, as this computer only has one.

The motherboard is Intel with I believe an 810 chipset. Couldn't find that out for sure. (54 year old eyes can't quite make out the print on there)

The bios looks right to me. It sees the DVD as Master and as the correct one.

I am beginning to suspect the hardware. I'm going to see if I can borrow an IDE cable from the techs at work tomorrow.

This is a bit frustrating. I maintain 31 servers at work, and here I can't get my personal computer to work @ 100%. Haha If I have to use a paper clip from now on, it's not the end of the world, but I'd really like it to work correctly.

And again, thank you for all the responses.

win_to_lin_migrant 05-20-2009 08:25 AM

Reboot, push the tray button just as the system powers on. Does it open then? If so you have confirmed that the drive(s) will open when the tray is empty.

chuckbuhler 05-20-2009 05:55 PM

Well, I tried a different IDE cable, and as expected, it made no difference.

I tried opening the drives during power up, and they did not open, with or with out a disk present.

Earlier when asked about the chipset I said that I thought it was a 810 chipset, that's wrong, it's 946GX chipset.

Went to Intel's site, and haven't had much luck finding anything for this that isn't Windows specific except graphics drivers.

Well, back to google seaching.

lazlow 05-20-2009 06:03 PM

If it will not open during boot up, it is not an OS issue.

All times are GMT -5. The time now is 08:51 AM.