-   Linux - Hardware (
-   -   whats up with sound (

csmaster2005 07-28-2004 03:19 PM

whats up with sound
ok I just installed fedora and I'm mostly a newbie linux user and for some reason I don't think I have any sound.

When I goto hardware browser and then sound cards, it detects my onboard soundcard (ac'97 audio controller)

Now I try to play sound, but not sure what's wrong... I downloaded an mid file and tried playing it with xmedia player, but nothing happens... the program is open but doesn't even load the title or anything... looks as if nothing is loaded.

Also, I put an mp3 on my desktop from a cd and when I try to open it with music player, it pops open and there is a progress type bar in the bottom right going but nothing happens.
This also happens when I try to add it to library, it doesnt load etc.

Is fedora not detecting my sound card properly or what?
How can I test the sound?

Peacedog 07-28-2004 05:58 PM

hi csmaster2005, welcome to lq. have you tried running a mixer and unmuting your sound?

csmaster2005 07-28-2004 06:03 PM

i've checked to see if it was muted... what do you mean by running a mixer?

Also why does it seem like nothing is loading on the program?

Peacedog 07-28-2004 06:28 PM


Originally posted by csmaster2005
i've checked to see if it was muted... what do you mean by running a mixer?

Also why does it seem like nothing is loading on the program?

have you tried running alsamixer, kmix, aumix, there are others, i'm not sure what you have installed. another point of consideration would be mp3 support for fedora, i remember that redhat did not support mp3's out of the box, i assume fedora follows suit, that would be something to check. are the files all local, or are you trying to play a cd, if this is the case it may be a permission problem w/the device. if you've run/opened a mixer and sound is not muted, this may be the problem. what does lsmod return, are the proper modules loaded for your card? i'm just throwing you some ideas where to look, hope this helps.
good luck.

csmaster2005 07-28-2004 06:47 PM

i'm lost now :(
Explain step by step what you need me to do heh.
I've tried playing mp3s locally, but no hope. How do I open a mixer? I've opened volume control and nothing is muted.
When I type lsmod in terminal, says command doesnt exist.
Wana try contacting me via aim please?
My username is same as forum.

Peacedog 07-28-2004 07:04 PM

if nothing is muted, can you play a wav file? for your mixers, you should have one of the mixers i mentioned, but, alsamixer runs from the terminal. for lsmod, it may not be in the users path, try /sbin/lsmod. i'd be glad to contact you personally via aim as suggested, but, that wouldn't help the forum or the people who search here. that said, there are others on this forum that may see this thread and have an idea of something i didn't think of or just a different point of view to the problem, so it's best to keep it here.
good luck.

csmaster2005 07-28-2004 07:08 PM

eh, well I already saw lsmod was in sbin but for some reason when I goto sbin directory and try to run it nothing happens. When I browse to it it seems that it is just a shortcut....

Peacedog 07-29-2004 06:33 AM

just do this from the terminal


after typing that just hit enter. then post the results.
good luck.

csmaster2005 07-29-2004 12:31 PM

i did, it gives a command not found for some reason :(

Euro 07-29-2004 02:28 PM

i have a strange problem with Sound on Red Hat 9 and on KDE, I'm a real n00b, but anyway, ive got no sound as well, the computer detects it, but what I normally do is go to the KDE cog thingy at the bottom left (by default anyway) and open up the menu, then System Settings, then Soundcard detection. There is a button that tests the sound, do it a couple of times and constantly answer yes, even if you can't hear it. I can noramlly hear souns after 3-4 tests.

good luck!

Euro 07-29-2004 02:30 PM

by the way, this is what I get if i tye /sbin/lsmod in Terminal:


[root@localhost dave]# /sbin/lsmod
Module                  Size  Used by    Not tainted
udf                    97504  1  (autoclean)
i810_audio            27528  2  (autoclean)
ac97_codec            13544  0  (autoclean) [i810_audio]
soundcore              6276  2  (autoclean) [i810_audio]
parport_pc            18756  1  (autoclean)
lp                      8868  0  (autoclean)
parport                36480  1  (autoclean) [parport_pc lp]
autofs                12948  0  (autoclean) (unused)
8139too                17896  1
mii                    3944  0  [8139too]
ipt_REJECT              3896  6  (autoclean)
iptable_filter          2380  1  (autoclean)
ip_tables              14648  2  [ipt_REJECT iptable_filter]
sg                    35980  0  (autoclean)
sr_mod                17912  2  (autoclean)
ide-scsi              11984  1
scsi_mod              106200  3  [sg sr_mod ide-scsi]
ide-cd                35196  0
cdrom                  33472  0  [sr_mod ide-cd]
ohci1394              19944  0  (unused)
ieee1394              48268  0  [ohci1394]
keybdev                2880  0  (unused)
mousedev                5428  1
hid                    21700  0  (unused)
input                  5792  0  [keybdev mousedev hid]
ehci-hcd              19592  0  (unused)
usb-ohci              21160  0  (unused)
usbcore                77696  1  [hid ehci-hcd usb-ohci]
ext3                  69984  1
jbd                    51220  1  [ext3]

mermxx 07-29-2004 03:16 PM

csmaster2005 - open a terminal window and type su this will change u into `root` for which u will have to supply ur password and then enter the command /sbin/lsmod this should then give the output u need to copy and paste

csmaster2005 07-30-2004 09:02 PM

I did it and got the below. But the thing is, when I goto sound card detection and play test sound I hear the sound...
My question is how can I play things such as mp3's? When I put a cd in, it loads the cd and I can see the cd name and song... but I don't hear any sound. I checked the volume controls and it isnt muted and it's up all the way..

Peacedog 07-31-2004 04:14 PM

2 things, have you installed mp3 support, you can get it here

do you have a sound cable attached to the cdrom?
good luck.

Malacandra 07-31-2004 04:36 PM

Not sure what Fedora uses, but SUSE has a graphical configuration utility which looks like a little hardware card in the system tray. Selecting that brings up a list of hardware which you can configure. When I go into the Sound card and click configure, then I have some other buttons. One is Volume. Clicking that I see a whole bunch of stuff, but the main thing: two sliders at the top: Master and PCM. Master was somewhere in the middle, but PCM was all the way down. I slid it up and voila!

I know this is SUSE, and you have Fedora, but surely there is a graphical hardware config utility you can use to get to the sound card's volumes.

Let us know what happens.

All times are GMT -5. The time now is 04:58 AM.