-   Linux - Hardware (
-   -   What can cause packet loss? (

Micah 03-12-2004 10:53 AM

What can cause packet loss?
What will cause my network card to start dropping packets?

Everything worked perfect but I ran out of space and couldn't install the latest gcc. So I rebuilt with a new distro (that already had it). Since rebuilding, my network cards will stop dropping packets when put under any load.

Examples of what causes the network to brake:
Opening a webpage with graphics (
Downloadign a file with lynx
FTP operations that are large ( list of kernels for 2.2.x)
vncserver (once someone connects)

Network cards:
IBM 10/100 EtherJet - 32bit Cardbus Adapter
Encore 10/100 Base-TX ethernet PC Card (uses rtl8139 chipset)

Kernels used: 2.2.17, 2.2.19, 2.2.26
PCMCIA-CS drivers used: 3.2.4, 3.2.7
Distributions used: Slackware 7.1, 8.0, 9.1
Computer: Thinkpad 760XL (Laptop) using PCMCIA interface for NICs

Again, my question is what 'could' be causing my network packets to start dropping?

Thanks for ANY input.

dushkinup 03-12-2004 11:04 AM

Poor network conditions.
Things like bad cables, bad network cards in the worse case.

It's hard to believe It's GCC who made you start loosing packets, but maybe. You should try testing your hardware on other computers if you can. And try testing the cables with a special device (I know someone who has one, dunno where he bought it).

Packet loss is a very bad thing (as you can see).
Get rid of it.

Micah 03-12-2004 11:36 AM

Oops... GCC caused me to rebuild my box. Since rebuilding everything has been out of whack. (When I tried to install GCC, I deleted all MAN files, all info files, all files I didn't know what they were for... After I was done, I couldn't open X Windows and GCC still couldn't be built) - So I reinstalled and got these problems.

As far as conditions goes:
I have tested this at work and at home with the same problems. At both locations I use different cables. I will change cables to see if that helps.

Micah 03-14-2004 01:38 PM

Ok, I have now tested my NIC with a Windows XP box and it works perfect! I have tested with other CAT5 cables and it still fails. Network cables test out fine (At work we have all the fun stuff =)

Anything else?

thelandrew 03-14-2004 02:00 PM

Um... I'm still a linux newbie, but I don't think your problem is linux per se, so if you had windoze on that system...

Packet loss on small peer to peer networks can be caused by almost anything. Check, in this order:

1) The cables. If possible, replace your cable with a known good cable. Don't test when you can replace.

2) The driver. An incorrect driver which appears to be correct can cause packet loss. Update the driver if possible. Confirm you have the BEST driver.

3) Cable Stress. Similar to (1) If a cable is often bent at a particular (sharp) angle, it may over time stop working EXCEPT when bent in that way.

4) Your NIC. Nics can fail in all kinds of interesting ways. In addition to electronic failure, I have seen NICs that suffer from "cable stress" in their rj45 ports. Replace the NIC if possible.





99) Cosmic Radiation. You'd be surprised how much harm a stray alpha particle can do to a data transmission. Seal your entire network behind 3 meters of lead...

100) Alien intervention. Maybe "they" are experimenting on you? Wear a tinfoil hat and your performance should improve.

Based on what you've already said, by bet is that you have a a bad or misconfigured driver for your NIC. How to fix? No Idea. You'll need someone who knows beans about linux. :)

-landrew the :newbie:

Micah 03-14-2004 03:24 PM

Lead is expensive and I don't have any tinfoil -- Thank good ness...

More Info:
My restoration of my backup completed and it works... I do get droppedpackets, BUT it recovers and continues!

What Config files do I need to look at? (A bit off topic)

NIC works perfect in other PCs (Windows anyhow)
The latest driver failed too... and it happens to different nics.

Micah 03-14-2004 09:36 PM

I fixed it!!! Drivers for both PCMCIA-CS and rtl8139.c...
Well... It doesn't stop working when it drops packets, instead it requests the packets again... Before it would just stall or kernel panic =)


These versions work:
rtl8139.c v1.13

ewtrowbr 03-14-2004 09:42 PM

I'm not a linux expert, but I know a good bit about networks. It sounds like whenever you have application traffic, your connection fails. Your nic is fine. Your driver is recent and should work.

Lemme guess... You can ping (64 byte packets) all day without problem.

Do an ifconfig and make sure your MTU is set to 1500. If it is set to anything else, IP fragmentation will fail, and you won't be able to use the internet properly. Also, check out your kernel config file to investigate any parameters that would cause IP fragmentation to fail.

The symptoms you report are generally symptoms of IP fragmentation failing, and this is usually due to MTU mismatch.

good luck.

Electro 03-15-2004 12:31 AM

You could try upgrading to 2.4 kernel version. There is a lot of improvements since 2.2 kernel version.

Try placing some switch hubs instead of just a passive hub.

Use a different netmask.

All times are GMT -5. The time now is 10:52 AM.