LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 01-12-2008, 07:56 AM   #1
Dragyn55
LQ Newbie
 
Registered: Jan 2007
Posts: 5

Rep: Reputation: 0
What am I doing wrong with my TV Tuner


I could use some help please! I'm running Ubuntu Gusty and I just bought a Sabrent Tv tuner. It's a saa7130 card and everything I've read says that it should use card=42 and tuner= 17. I believe I set everything correctly but the card still won't work with tvtime. All I get is the blue screen that says no signal. But if I set it to a channel and go to composite I get a picture but no sound. I have no idea what I'm doing wrong. Also I noticed that card 42 is for the Sabrent card with an fm tuner. Mine doesn't have the fm. Could that make a difference? Any help would be greatly appreciated.
 
Old 01-13-2008, 01:00 AM   #2
elliott678
Member
 
Registered: Mar 2005
Location: North Carolina
Distribution: Arch
Posts: 977

Rep: Reputation: 74
I've got a Sabrent saa7130 knockoff without an FM tuner, I have no problems using the 'card=42' option, I just have a useless /dev/radio0 device.

Not sure what your issue could be, after I found out what my card was a clone of, it works great.
 
Old 01-13-2008, 01:24 AM   #3
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,363

Rep: Reputation: 172Reputation: 172
I do not know about your card but some cards you have to run an audio patch cord from the output on the tv card to the input of the sound card.
 
Old 01-13-2008, 01:39 AM   #4
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,716
Blog Entries: 3

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
What am I doing wrong with my TV Tuner

Quote:
Originally Posted by Dragyn55 View Post
I could use some help please! I'm running Ubuntu Gusty and I just bought a Sabrent Tv tuner. It's a saa7130 card and everything I've read says that it should use card=42 and tuner= 17. I believe I set everything correctly but the card still won't work with tvtime. All I get is the blue screen that says no signal. But if I set it to a channel and go to composite I get a picture but no sound. I have no idea what I'm doing wrong. Also I noticed that card 42 is for the Sabrent card with an fm tuner. Mine doesn't have the fm. Could that make a difference? Any help would be greatly appreciated.
well the first thing you need to make sure of that your module is loaded or you get a dead screen type sudo modprobe videodev this will load your module. and now it can load v4L. I use the gspca model to allow the grabber program to use the device. modprobe videodev and get gspca module from ubunto repo. apget. and modprobe gspca. I use xawtv for my grabber. But I believe ubuntu has some gui program also. type lsmod and if you do not see videodev then you know the problem.
 
Old 01-13-2008, 04:07 PM   #5
Dragyn55
LQ Newbie
 
Registered: Jan 2007
Posts: 5

Original Poster
Rep: Reputation: 0
First off Thank all of you for the reply. I did everything that Drakeo recommended and videodev does show up. but I still only have a picture if I switch TVtime to composite instead of television. And still no sound. I also tried different grabber programs. Zapper which is the xawtv equivalent for gnome shuts down when I try to edit any preferences and xawtv doesn't even come on. As for the sound. I have tried all ways with no luck. I had a Miro pctv card in it before and had to plug the audio out line directly into the mp3 jack on my speakers to get sound, but that didn't work this time. ellot678 how did you find out exactly what card yours was a clone of? I peeled the sticker off of the tuner to check the numbers. I know that the tuner is right but not sure if the card is correct. Here is the output from lsmod. videodev is there, but I don't know if everything else is correct. Again Thanks for the help.

Module Size Used by
af_packet 24840 2
binfmt_misc 12936 1
rfcomm 42136 2
l2cap 26240 11 rfcomm
bluetooth 57060 4 rfcomm,l2cap
ipv6 273892 16
ppdev 10244 0
speedstep_lib 6404 0
cpufreq_conservative 8072 0
cpufreq_stats 7232 0
cpufreq_userspace 5280 0
cpufreq_ondemand 9612 0
freq_table 5792 2 cpufreq_stats,cpufreq_ondemand
cpufreq_powersave 2688 0
sbs 19592 0
dock 10656 0
ac 6148 0
video 18060 0
container 5504 0
button 8976 0
battery 11012 0
bt878 11832 0
bttv 177012 1 bt878
i2c_algo_bit 7428 1 bttv
btcx_risc 5896 1 bttv
tveeprom 16784 1 bttv
lp 12580 0
saa7134_alsa 15392 0
snd_mpu401 9640 0
snd_mpu401_uart 9600 1 snd_mpu401
snd_seq_dummy 4740 0
snd_seq_oss 33152 0
snd_seq_midi 9600 0
snd_rawmidi 25728 2 snd_mpu401_uart,snd_seq_midi
snd_seq_midi_event 8448 2 snd_seq_oss,snd_seq_midi
tuner 63144 0
snd_seq 53232 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_intel8x0 34972 1
snd_ac97_codec 100644 1 snd_intel8x0
snd_seq_device 9228 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
ac97_bus 3200 1 snd_ac97_codec
snd_pcm_oss 44672 0
snd_mixer_oss 17664 1 snd_pcm_oss
saa7134 129100 1 saa7134_alsa
analog 13344 0
snd_pcm 80388 4 saa7134_alsa,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer 24324 2 snd_seq,snd_pcm
video_buf 26244 3 bttv,saa7134_alsa,saa7134
compat_ioctl32 2304 2 bttv,saa7134
serio_raw 8068 0
parport_pc 37412 1
parport 37448 3 ppdev,lp,parport_pc
snd 54660 15 saa7134_alsa,snd_mpu401,snd_mpu401_uart,snd_seq_oss,snd_rawmidi,snd_seq,snd_intel8x0,snd_ac97_codec, snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore 8800 1 snd
gameport 16776 1 analog
ir_kbd_i2c 9872 1 saa7134
ir_common 35460 3 bttv,saa7134,ir_kbd_i2c
pcspkr 4224 0
videodev 29312 2 bttv,saa7134
v4l2_common 18432 4 bttv,tuner,saa7134,videodev
v4l1_compat 15364 3 bttv,saa7134,videodev
psmouse 39952 0
snd_page_alloc 11400 2 snd_intel8x0,snd_pcm
nvidia 4718960 32
sis_agp 10116 1
i2c_sis96x 6404 0
shpchp 34580 0
pci_hotplug 32704 1 shpchp
agpgart 35016 2 nvidia,sis_agp
i2c_core 26112 8 bttv,i2c_algo_bit,tveeprom,tuner,saa7134,ir_kbd_i2c,nvidia,i2c_sis96x
joydev 11328 0
evdev 11136 5
ext3 133896 1
jbd 60456 1 ext3
mbcache 9732 1 ext3
sg 36764 0
sr_mod 17828 0
cdrom 37536 1 sr_mod
sd_mod 30336 3
8139too 27776 0
usbhid 29536 0
hid 28928 1 usbhid
pata_sis 15236 2
floppy 60004 0
8139cp 25088 0
mii 6528 2 8139too,8139cp
ata_generic 8452 0
libata 125168 2 pata_sis,ata_generic
scsi_mod 147084 4 sg,sr_mod,sd_mod,libata
ohci_hcd 22916 0
usbcore 138632 3 usbhid,ohci_hcd
thermal 14344 0
processor 32072 1 thermal
fan 5764 0
fuse 47124 1
apparmor 40728 0
commoncap 8320 1 apparmor
 
Old 01-13-2008, 05:37 PM   #6
elliott678
Member
 
Registered: Mar 2005
Location: North Carolina
Distribution: Arch
Posts: 977

Rep: Reputation: 74
I found out which card I have by trial and error, I went though all 108 card options to find the best one and I didn't have to set a tuner option, even though I checked all 69 of them to be sure I had the ideal setup. It was a dirt cheap card from eBay with terrible documentation and barely working Windows drivers.

I have to have an audio cable looped from the output of the card to the line-in on my board to get sound.

Do you have another TV tuner in this system at the moment?
 
Old 01-13-2008, 08:28 PM   #7
Dragyn55
LQ Newbie
 
Registered: Jan 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Ni I took the old card out. It worked fine for viewing TV, but it had no recording capabilities. I wanted to be able to record shows I miss because of my work schedule. I used a script that goes through each card until it finds the right one. None worked so I stuck with 42. Here's the script.


#/bin/sh
MAXTUNER=69
i=0

while [ $i -lt $MAXTUNER ];
do
sudo rmmod saa7134_alsa saa7134
sudo modprobe saa7134 card=$i
echo "Actual card is:" $i
sleep 1 # this is to make sure /dev/video is registered when tvtime starts
tvtime
i=$(($i+1))
done
 
Old 01-13-2008, 09:09 PM   #8
elliott678
Member
 
Registered: Mar 2005
Location: North Carolina
Distribution: Arch
Posts: 977

Rep: Reputation: 74
Why are the bttv modules loaded, aren't those for a tuner card? If so, that could be interfering with the saa7134 drivers.

Last edited by elliott678; 01-13-2008 at 09:11 PM.
 
Old 01-14-2008, 03:32 AM   #9
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,716
Blog Entries: 3

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
go to your program that is a grabber you know the one that you use to watch tv like my grabber. then configure your sound so it can use your alsa or OSS sound system. then you will be able to hear. You have to realize that all mplayers like xine gxine are all grabber programs. as a matter of fact you can use your xine to watch your tv if you wanted to by configuring it. so configure your sound in your program. Or you will never be able to hear see or record and if you need a sound cable like my nvidia card then get one and link your card to sound just like the cdrom has to.
 
Old 01-14-2008, 06:40 PM   #10
Dragyn55
LQ Newbie
 
Registered: Jan 2007
Posts: 5

Original Poster
Rep: Reputation: 0
ellot678 did you check to see if thr bttv modules load on yours? If not any idea on how I get rid of them?

Drakeo, I'm using the cable from audio out to audio in on my sound card, but it may not work until I get my card to work properly. I will try all of the programs I can use as a grabber when it's working to see which I prefer. Thanks
 
Old 01-14-2008, 06:48 PM   #11
elliott678
Member
 
Registered: Mar 2005
Location: North Carolina
Distribution: Arch
Posts: 977

Rep: Reputation: 74
Quote:
Originally Posted by Dragyn55 View Post
ellot678 did you check to see if the bttv modules load on yours? If not any idea on how I get rid of them?
Nope, they are for a totally different card. You'll have to find out why the module is loading, do you have it listed in a configuration file somewhere? If the distro is loading it on its own you need to blacklist it. Though if the hardware isn't there anymore it shouldn't be auto loading it, stranger things have happened though.

You can blacklist it by adding the following to /etc/modprobe.d/blacklist:
Code:
blacklist bttv
 
Old 01-15-2008, 02:35 PM   #12
Dragyn55
LQ Newbie
 
Registered: Jan 2007
Posts: 5

Original Poster
Rep: Reputation: 0
I blacklisted bttv, but it still shows up. There's no change in the card. Perhaps I just got a faulty card. Thanks for all of your help.
 
Old 01-15-2008, 02:52 PM   #13
elliott678
Member
 
Registered: Mar 2005
Location: North Carolina
Distribution: Arch
Posts: 977

Rep: Reputation: 74
It showed up after a reboot while being blacklisted? Then Ubuntu isn't loading it automatically, you must have put it in a config file somewhere to make the old card work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
What is wrong with reiserfs? wrong free space mesh2005 Linux - General 1 05-03-2007 07:21 AM
kernel: tuner: tuner type not set gadhiraju Linux - Hardware 2 10-05-2004 12:17 PM
the most compatible TV tuner cards, or FM/AM Tuner aliiscool Linux - Hardware 1 06-06-2004 02:59 PM
tv tuner for mercury tv tuner card sandesh_hs Linux - Hardware 1 02-22-2004 03:20 AM
TV Tuner / AM&FM Tuner hardware N3WBI3 Linux - Hardware 2 08-01-2002 10:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration