-   Linux - Hardware (
-   -   Weird ALSA Errors (

Mr_Munkey 06-10-2005 11:19 AM

Weird ALSA Errors
Hello everyone,

My manager built both his and my computers with identical parts with a VIA sound card. These are EXACTLY identical... down to the brand of RAM. He compiled his kernel, and sound works just fine. He then sends me over his .config file. I load it up, compile the kernel, and I get these errors when ALSA starts up:

FATAL: Module snd_pcm_oss not found.
FATAL: Module snd_mixer_oss not found.

This is on Slackware 10.1, updated nightly with slackware-current via swaret. I run ldmod and get this:

Module Size Used by
nvidia 3708548 12

My manager has a heck of a lot more. I also know that I compiled in my sound card. I've recompiled about 5 times now using modules, building it into the kernel, using 2.6.10 instead of 2.6.11 etc.

Anyone have any ideas why I am missing the modules snd_pcm_oss and snd_mixer_oss? Those were compiled in too.


Mr_Munkey 06-10-2005 11:26 AM

Also, here's the pertinent line from lspci:

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)


Electro 06-10-2005 04:25 PM

Did you do `make mrproper` before you add the .config file. Also is your manager and you using a vanilla kernel. Also is it the same. I suggest using kernel version 2.6.11 because there is some permission problems with kernel version <=2.6.10 when a normal user access CD/DVD drive to write a disc even if the device has permission of 666 or 777. The root user have to be used to write to a CD/DVD disc, so this can create a security risk.

I usually compile sound as module (soundcore) and only compile OSS as modules. Then I download the latest ALSA drivers, libraries, and utilities.

Mr_Munkey 06-10-2005 04:56 PM

I did try a few times with make mrproper, and copy my config file back. I use menuconfig when making my kernels. I also tried compiling everything to do with sound as a module. I might have only done that with alsa, and not sound completely, so I'll revisit that.


Mr_Munkey 06-10-2005 07:45 PM

I compiled all the sound as a module, and it's working just fine now :)

Thanks for the help!

All times are GMT -5. The time now is 09:38 PM.