LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   WebGL + Linux + Acer Notebook (http://www.linuxquestions.org/questions/showthread.php?t=4175435300)

spirit1988 11-02-2012 10:01 AM

WebGL + Linux + Acer Notebook
 
Hi! I have an Acer 5720 with Ubuntu 12 (not sure if it's 12.04 or 12.10, but I don't think it makes much difference).

When I enter to http://get.webgl.org/ with Chrome I got:

Hmm. While your browser seems to support WebGL, it is disabled or unavailable. If possible, please ensure that you are running the latest drivers for your video card.


My video card supports OpenGL 2.1:

glxinfo | grep -i "OpenGL version"
OpenGL version string: 2.1 Mesa 8.0.4

I really would like to use WebGL because I want to start developing 3D apps with Javascript. I am missing a driver install?

If I run an lspci:

(...)

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 03)

I've tried with google-chrome --ignore-gpu-blacklist but didn't work.


I've just realized WebGL works in Firefox in my notebook. Not sure why is not working in Chrome.

gradinaruvasile 11-03-2012 03:12 AM

It DOES make a difference. Good or bad, depends on the situation. Newer releases have newer kernels + newer drivers. How they perform is another story.
Now, the integrated intels have the worst drivers for Linux (in addition of being the worst integrated graphics). They do work with OpenGL, but not that well.

Se here some details:

http://www.khronos.org/webgl/wiki/Bl...sAndWhitelists

https://wiki.mozilla.org/Blocklistin...Drivers#On_X11

I ran WebGL on Firefox/Opera/Chromium with a A4-3400 APU + 12.10 drivers, nvidia 8200 with the 304 series drivers, so it works with nvidia and AMD cards with the proprietary driver.

But your card has to have some support for certain OpenGL features and im not so sure about intel cards such as yours.

Certain features depend on the browsers implementation. You might try the latest build of Chromium with this script (installs/upgrades to the latest version):

Code:

#!/bin/bash
unset basehttp
unset latest
cd /tmp/
rm LATEST* > null
rm LAST_CHANGE* > null
rm chrome-linux.zip
rm chrome-linux.zip.*

basehttp=http://commondatastorage.googleapis.com/chromium-browser-snapshots/Linux

echo "Downloading latest version information..."
wget --quiet $basehttp/LAST_CHANGE

if [ -f $HOME/chrome-linux/LAST_CHANGE ]
  then
  echo "Installed dev version is `cat $HOME/chrome-linux/LAST_CHANGE`"
  else
  echo "Cannot get Google Chromium version - not installed?"
fi

echo "Latest Chromium Dev version is `cat /tmp/LAST_CHANGE`"

if [ $((`cat /tmp/LAST_CHANGE`)) -eq $((`cat $HOME/chrome-linux/LAST_CHANGE`)) ]
then
  echo " You have the latest version of Chromium Browser"
  exit 0
else

read -p "Press any key to continue installation or Ctrl-C to abort"
export latest=`cat /tmp/LAST_CHANGE`
echo "Downloading latest Chromium build..."
wget $basehttp/$latest/chrome-linux.zip && rm -rf $HOME/chrome-linux/

echo "Unpacking new version..."
unzip -o -qq /tmp/chrome-linux.zip -d $HOME/ && mv /tmp/LAST_CHANGE $HOME/chrome-linux/

echo "Creating links..."
if [ -d $HOME/bin/ ]
  then
        echo "The bin folder already exists!"
  else
  mkdir $HOME/bin
fi

echo "Creating menu link"

mkdir -p $HOME/.local/share/applications/

echo -e '[Desktop Entry]\r
Encoding=UTF-8\r
Version=1.0\r
Name=Chromium Linux\r
Comment=Browse the WWW\r
Type=Application\r
Exec='$HOME'/chrome-linux/chrome --enable-click-to-play\r
Terminal=false\r
Categories=Network\r
Name[en_US]=Chromium Browser\r
Comment[en_US]=Browse the WWW\r
Icon[en_US]='$HOME'/chrome-linux/product_logo_48.png\r
Icon='$HOME'/chrome-linux/product_logo_48.png\r' > $HOME/.local/share/applications/chromium-linux.desktop

rm $HOME/bin/chromium-linux

echo -e '#!/bin/bash\n
$HOME/chrome-linux/chrome --enable-click-to-play $1' > $HOME/bin/chromium-linux

chmod +x $HOME/bin/chromium-linux

#ln -s /opt/google/chrome/libpdf.so $HOME/chrome-linux/
#ln -s /opt/google/chrome/libgcflashplayer.so $HOME/chrome-linux/

rm /tmp/chrome-linux.zip
echo "Installation/Upgrade complete"
exit 0
fi



All times are GMT -5. The time now is 09:38 PM.