-   Linux - Hardware (
-   -   Webcams? (

SlowCoder 09-03-2007 07:27 PM

I'm interested in purchasing a webcam for communications with the family.

I've looked through the LQ HCL, but most of the information there is outdated, as compared to cameras available for purchase today.

The Logitech QuickCam Pro 5000, for instance, is not supported by the drivers, while many of its predecessors are.

What are you using, and how happy are you with it?

maroonbaboon 09-04-2007 02:16 AM

A lot of cheapie cameras are supported by the GSPCA/SPCA5xx driver from M.Xhaard.

Some of the newer better quality ones like the QC Pro 5000 use the UVC driver (site seems to be down at the moment).

I don't think either is currently supported in the standard kernel, but the GSPCA driver is easy to compile and install. Never tried the UVC driver. Together they seem to cover a large part of the current webcam market.

SlowCoder 09-04-2007 07:34 PM

Thank you maroon.

How easy is it to get a camera online and able to chat live? I want to use it for long distance communication with family, not just record video clips.

What applications do you use for live communication?

maroonbaboon 09-04-2007 10:35 PM


Originally Posted by SlowCoder (Post 2881395)
How easy is it to get a camera online and able to chat live?

Never tried video chat, so can't advise on what works. I think the spca5xx driver only supports the video4linux interface while the UVC driver supports only video4linux2, which may be a consideration.

The Ekiga site has a list of tested hardware, which might be useful if you are interested in that particular app.

SlowCoder 09-05-2007 11:50 AM

Ok. I ended up purchasing the Logitech QuickCam STX, which is in the Gspca/Spca5xx compatibility list. I downloaded and "make;make install"ed the gspcav1-20070508 driver, and I can now view myself (woohoo!) with ekiga locally.

Now I can't get ekiga to playback the audio from my built-in camera microphone.

SlowCoder 09-05-2007 02:29 PM

Well, after some tinkering, and apparently confusing the heck out of my hardware (lost sound output capabilities), I think I got it working! Thank you for your assistance.

All times are GMT -5. The time now is 07:17 AM.