-   Linux - Hardware (
-   -   Webcam usb Trust WB-3100P (

Pier 01-22-2006 09:58 AM

Webcam usb Trust WB-3100P
Hi everyone,
I lately got a Trust WB-3100P webcam as a gift but I still haven't managed to make it to work.
This is what I did so far:
1) switched from ker 2.4.31 to and compiled in
a) video for linux support
b) USB S9C10X which seems to be the one this webcam needs to work properly
2) installed libdv
3) installed libquicktime
4) MAKEDEV video
5) changed permissions to the device:
pier@darkstar:/dev$ ls -al /dev/video lrwxrwxrwx 1 root root 6 2006-01-21 12:50 /dev/video -> video0
6) yet xawtv returns:
pier@darkstar:~$ xawtv -d ot i /dev/video

This is xawtv-3.93, running on Linux/i686 (
can't open /dev/video0: No such device
v4l-conf had some trouble, trying to continue anyway
v4l2: open /dev/video0: No such device
v4l2: open /dev/video0: No such device
v4l: open /dev/video0: No such device
no video grabber device available
7) furthermore:
pier@darkstar:~$ xawtv -hwscan
This is xawtv-3.93, running on Linux/i686 (
looking for available devices
port 61-61
type : Xvideo, image scaler
name : ATI Radeon Video Overlay
8) dmesg returns:
-------- snip -------------------------------------------------------------
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
usb 4-2: new full speed USB device using ohci_hcd and address 2
usb 4-2: SN9C103 PC Camera Controller detected (vid/pid 0x0C45/0x60AF)
-------- snip -------------------------------------------------------------
Linux video capture interface: v1.00
-------- snip ------------------------------------------------------------
9) lsmod returns:
Module Size Used by
snd_pcm_oss 49824 0
snd_mixer_oss 14720 1 snd_pcm_oss
lp 8516 0
ipv6 193280 14
parport_pc 23108 2
8250_pnp 8448 0
8250 16020 1 8250_pnp
serial_core 15104 1 8250
sis_agp 6148 1
shpchp 36800 0
pci_hotplug 8964 1 shpchp
ohci_hcd 16388 0
ehci_hcd 24584 0
sis900 16640 0
mii 4480 1 sis900
snd_ens1371 18528 5
gameport 10760 1 snd_ens1371
snd_rawmidi 19104 1 snd_ens1371
snd_seq_device 7052 1 snd_rawmidi
snd_ac97_codec 81056 1 snd_ens1371
snd_pcm 76168 4 snd_pcm_oss,snd_ens1371,snd_ac97_codec
snd_timer 19460 2 snd_pcm
snd 46052 16 snd_pcm_oss,snd_mixer_oss,snd_ens1371,snd_rawmidi,snd_seq_device,snd_ac97_codec,snd_pcm,snd_timer
soundcore 6880 1 snd
snd_page_alloc 8456 1 snd_pcm
snd_ac97_bus 2048 1 snd_ac97_codec
ppa 10376 0
ide_scsi 12420 0
agpgart 26568 1 sis_agp
10) lsusb returns:
root@darkstar:/home/pier# lsusb
Bus 004 Device 002: ID 0c45:60af Microdia
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

....don't know where to bang my head next... I've almost given up hope :(

Thanks for any help in solving this,

Maestro485 01-22-2006 11:19 AM

I have a similar problem, however no solution. I have a USB webcam (Xirlink inside, some generic name outside) and the driver is included in at least the newer kernels. However, as you have noticed, the USB device (/dev/usbdev with some numbers) doesn't show up as a v4l device (/dev/video). I know that my v4l is working correctly because I have a TV card and it works just fine (/dev/video0).

I tried a less-than-graceful fix of simply creating a link called /dev/video1 and pointing it to the proper USB device, but that didn't work and was pretty much doomed from the start. I also tried using the USB device as the video device by passing xawtv the -c flag, but no luck there either.

Also, I have never had any luck with xawtv even with the working TV card, so you might not want to trust it if it fails.

I will keep on tinkering here and let you know if I figure something out. In the meantime, does anyone have any advice?


Pier 01-22-2006 02:30 PM

Thanks Matt,
no luck so far ... just a big headache!
Link down seems to point out that the device is hardly supported.... Giving it away will save me a lot of wasted time .


All times are GMT -5. The time now is 03:33 PM.