LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   webcam install (https://www.linuxquestions.org/questions/linux-hardware-18/webcam-install-216964/)

d1l2w3 08-12-2004 10:29 PM

webcam install
 
Trying to install Micro Webcam IC150C.
Continusously get the error message:
Could not connnect to video device /dev/video0.
Please check connection.

/dev/video0 exists.
Any ideas on solving this problem.

dlw

slackist 08-13-2004 05:31 AM

What are the file permissions on /dev/video0?

Post the output of ls -l /dev/video0

d1l2w3 08-13-2004 09:05 AM

permissions for /dev/video0 are 'don:video"
ls -l /dev/video gives the following:
crw------- 1 don video 81, 0 Aug 13 06:28 /dev/video0

d1l2w3 08-13-2004 09:12 AM

This is what happens when I try to use 'xawtv'.
This is xawtv-3.91, running on Linux/i686 (2.6.3-7mdk)
can't open /dev/v4l/video0: No such file or directory
v4l-conf had some trouble, trying to continue anyway
v4l2: open /dev/v4l/video0: No such file or directory
v4l2: open /dev/v4l/video0: No such file or directory
v4l: open /dev/v4l/video0: No such file or directory
no video grabber device available

Are the two related.
How do I find out if v4l exists?

dlw

slackist 08-13-2004 09:21 PM

Here is my set-up
Code:

mark@~/$ ls -l /dev/video0
crw-rw-rw-    1 root    sys      81,  0 Mar 10  2003 /dev/video0

so try (as root) chmod 766 /dev/video0 to give read and write permissions to others and world but I don't think that is the problem,

I'm not really up on this stuff, esp Mandrake, is user don a member of the group video?

As for the v4l part I really can't say, when I installed xawtv (version 3.93 BTW) I only had to change permissions on /dev/video0 to give rw to others since it belonged to root and it worked, that's why I suggested looking at the permissions first.

To find out if v4l exists do locate v4l
Maybe the manual pages on v4l will give you some ideas?

Sorry I can't help more,

mark

NEWSFLASH I just tried my camera out and it doesn't work any more :scratch: :cry: hopefully somebody who knows what they are doing will chime in lol :o

slackist 08-14-2004 06:09 AM

This is leaving me :scratch:

After a bit of googling if I run xawtv -noxv my webcam (creative webcam3 works fine)
so I think I am going to have to hit the man pages and google more, sorry I couldn't help you more,

mark

d1l2w3 08-14-2004 10:01 AM

Webcam problem
 
Has anyone been able to get a Micro IC150C working with MDK 10?
I keep getting a cannot connect to '/dev/video0' error.
'/dev/video0' is there. I have permission.
'sane-find-scanner' shows it as a 0x0461 0x0815 libusb:002:003

Any ideas on how to solve this.

dlw

Slyder42 08-20-2004 10:00 AM

Re: Webcam problem
 
Quote:

Originally posted by d1l2w3
Has anyone been able to get a Micro IC150C working with MDK 10?
I keep getting a cannot connect to '/dev/video0' error.
'/dev/video0' is there. I have permission.
'sane-find-scanner' shows it as a 0x0461 0x0815 libusb:002:003

Any ideas on how to solve this.

dlw

I might be of SOME help, but you won't get anywhere looking for that.... Assuming you are running X-desktop...If you go to hardware browser... that maybe the model number... but who is the chipset manufactured by? It definitely is NOT Micro Innovations. I got almost the same webcam and trying to find the same thing. I'll keep posting and see what I can find.

wytiger 08-20-2004 05:19 PM

I have the same thing! So I'll share what I have so far...

The spca50x driver supposedly works with it (http://spca50x.sourceforge.net), and more importantly, if you are running a 2.6.x kernel, use the driver here:
http://mxhaard.free.fr/download.html

I can compile the driver on my FC2 box, and it is recognized as an IC200C (not an IC150C, but I imagine that may not be an issue), but the screen only shows black using gspy, gqcam, etc.

Maybe you can have better luck with a different OS? Please let me know.

wytiger 08-24-2004 06:18 PM

You need the spca50x drivers, located here: http://mxhaard.free.fr/download.html

sevi 09-11-2004 01:53 PM

genius VideoCam Express V2
 
hi, i was trying to install the spca driver.
I've done the "make", and "make install" commands.

Quote:

If you have made install, do as root: modprobe spca50x
When I tried, i get the error message:

Quote:

modprobe: command not found
Where is the modprobe command???

I'm using Fedora Core 2, and a Genius Videocam Express v2 camera
The camera is on the list of supported cameras (in the spca readme file)
How to install the v4l driver? I have gnome-meeting with v4l plugin installed
Sorry, if its a silly queston, i'm a newbie :) Thx for the help

sorri for the bed inglishness :D:D

d1l2w3 09-12-2004 11:07 AM

Sorry about the delay. Went on vacation.
Downloaded 'spca' as suggested.
These are the instructions on how to install.

Kernel 2.4.x
configure your kernel
make dep
go to the spca5xx directories
make clean (to be sure)
make
if all goes right as root :
make install


Here is what happens when attemping to install.

[root@localhost /]# make dep
make: *** No rule to make target `dep'. Stop.

Tried as 'user' and 'root.'

How do I solve this?

dlw

wytiger 09-13-2004 11:26 PM

SUCCESS! Well, almost...

Even though the IC150 and IC200 share vendor and product IDs, they are different chipsets. I will have more info tomorrow since I did the work at the office, but changing the source to use the spca561 bridge worked for me.

Michel Xhaard has some info here, showing that the IC150 is in test, so I made some changes to the source to reflect this (latest release 10092004), and I am now able to see video through my IC150 using spcaview.

wytiger 09-13-2004 11:31 PM

For those that may be watching this thread instead of this one, I have had some success with the IC150. Since I did the work at the office, I will post my findings tomorrow for you.

XavierP 09-14-2004 01:16 AM

Moved: This thread is more suitable in Linux-Hardware and has been moved accordingly to help your thread/question get the exposure it deserves. I have asked for this post to be merged with your other, identical one, to keep the discussion in one place.

Next time it will be closed.


All times are GMT -5. The time now is 04:53 PM.