-   Linux - Hardware (
-   -   WD MyBook World Edition II 4TB - Reusing drives (

Duron 05-24-2011 12:22 PM

WD MyBook World Edition II 4TB - Reusing drives
This is a problem I've been working at on and off for quite a long time now. I acquired one of these devices from a thrift store and eventually decided that the drives would serve better mounted in my desktop PC, rather than hooked up to a router where large-scale backups are made unbearably slow.

What I quickly discovered is that these drives don't want to appear to any OS. The Windows installer doesn't see them. My Linux distro (at the time) didn't see them. A GParted live CD didn't see them. DBAN didn't see them. The BIOS, however, saw them, so I banged my head against a few possible solutions.

Martin Hinner's blog seemed promising but didn't have the information I wanted. This blog only had disassembly guides/photos, and no info (that I was able to find) on actually getting the drives to work in a Linux system.

I'd love to have an extra 4TB of storage in my desktop. Anybody got tips?

16pide 05-24-2011 01:32 PM

please run this, and post it here:

fdisk -l

Duron 05-24-2011 06:10 PM

Running those commands straight from a live CD (my desktop presently only runs Windows) didn't turn up anything, except for the CD's filesystem from df.

However, the newest live version of GParted (0.8.0-5) was able to recognize these drives and display them with the xfs filesystems they came on. One of my drives, I'm afraid, is faulty. The MyBook would tell me this in the web interface, and GParted confirmed it by throwing up error messages when I tried to make a new disklabel and Windows completely not recognizing it after I tried to reformat it.

As for the other drive, I reformatted it and it showed up in Computer Management under Administrative Tools in Windows. I gave it a drive letter and it works.

Funny how I always stumble upon the solution to a problem about 45 minutes after I post it to a forum.

16pide 05-25-2011 12:57 AM

fdisk -l didn't show anything because you did not run it as super user (sudo or su -).
Your disk was not mounted because the filesystem was xfs, and for this to work you would have needed to install the xfs rpm.

Anyway, you've now reformated to ntfs I suppose, it work and you're happy, so enjoy!

cascade9 05-26-2011 01:32 AM

If its an advanced format drive, you need to becareful about how you partition the drive.

Using XP (or most of the linux partition tools) will result in 'unaligned' partitions, which can have a major effect on speed, and could have an effect on the long term life of the drive.

All times are GMT -5. The time now is 07:03 PM.