-   Linux - Hardware (
-   -   Wanted: 802.11n usb wifi adapter dongle for linux (

jdkaye 11-05-2013 11:39 PM

Wanted: 802.11n usb wifi adapter dongle for linux
This is for my desktop which has no built-in wifi adapter. I am currently using a ZyXel dongle which works fine using the zd1211-firmware package. The problem is it does not support 802.11n. It only has 802.11b/g support and this results in a 33% loss in connection speed.

I made the mistake of ordering a SAVFY dongle from Amazon but can't get it to work. I should have read the reviews before ordering it. They all say it is a piece of junk. In any event it cost 5.95 which I have written off.

Can anyone recommend a dongle supporting 802.11n which actually does work with linux and is easy to install or at least has clear instructions. I found this one: IOGEAR Compact Wireless-N USB Adapter GWU625 (Black), also on Amazon but would appreciate your personal recommendations for one that is known to play nicely with linux.

Thanks for your help.

aus9 11-06-2013 02:29 AM

not sure if you can see the aussie ebay link

since you are on debian it needs firmware-realtek (its name on debian sid) from the non-free apt source
if you can't see the ad some features are:

Chipset: Realtek 8191
RF frequency: 2412-2462Mhz (North America); 2412-2472Mhz (Europe); 2412-2484Mhz (Japan)

Data security: 64/128-bit WEP Encryption WPA, WPA-PSK, WPA2-PSK, TKIP/AES

ebay your country and try terms like 300Mbps Wireless USB WiFi Adapter linux as it also says
Operating system: Windows 2000, XP 32/64-bit, Vista 32/64-bit, Linux, MAC OS x

it comes with a cd but you won't need it

good luck

qlue 11-06-2013 02:42 AM

If it's a desktop, wouldn't it be better to use an internal WiFi card?

jdkaye 11-06-2013 02:44 AM

Thanks for that, aus9. I must be blind or senile but I can't find the brand name (to find a closer supplier than Australia). Yes, I have the firmware-realtek package in my repos. Do you happen to know the brand name of this product?
Thanks again,
Update: I looked for it under "Realtek" and found it on and have now ordered it. If I understand correctly I install the firmware-realtek package, shut down the machine, plug in the dongle and restart and the system should find the realtek wifi adapter. Is that correct?

jdkaye 11-06-2013 02:47 AM


Originally Posted by qlue (Post 5059167)
If it's a desktop, wouldn't it be better to use an internal WiFi card?

Why? My ZyXel dongle works perfectly well and has done so for a number of years. It still works now but it doesn't support 802.11n so I don't get all the speed my wifi connection is capable of. That's why I'm looking for another dongle.

brianL 11-06-2013 07:55 AM

Try this one: the Edimax EW-7811UN.

jdkaye 11-06-2013 11:28 AM

Thanks Brian. Too late though. I've already ordered the Realtek one suggested by Aus9. I'll wait till I've received the Realtek and successfully installed it before marking this thread as solved. Thanks again to all who answered.

aus9 11-06-2013 05:00 PM


If I understand correctly I install the firmware-realtek package, shut down the machine, plug in the dongle and restart and the system should find the realtek wifi adapter. Is that correct?
not for debian sid, once you have package installed pls look under your existing system you should see
/lib/firmware/ and folders include rtlwifi and RTL<NUMBER>

as I can't guarantee you have exactly my model, if the folders exist you have the firmware installed

2) then plug in your dongle and run lsmod you should see a module begin with r and most likely end in u

3) oops forgot to mention, before it arrives pls install a gui for wifi '

this baby also allows you to setup wired if you need to
to never connect to other discovered networks
and most importantly save your wpa2 key

of course I assume you can get into your router to setup
WPA2/PSK or AE5 encryption?

jdkaye 11-06-2013 11:25 PM

Thanks again, Aus9. I think you misunderstood. I have been using a dongle for several years and have no problem connecting to my router with my ZyXel dongle with zd1211-firmware. I prefer to use wicd-curses for my configuration but I think that amounts to the same thing. I do have both rtlwifi and RTL8192SU folders in my /lib/firmware folder (along with the zd1211 folder which I used for my ZyXel dongle). The problem was that ZyXel doesn't support 802.11n (only 802.11b/g) which is the reason I was looking for a newer dongle.

aus9 11-06-2013 11:43 PM

aah yes I am senile too you know

I can confirm its a n cat dongle.

with a gui, its easier to ignore some networks so not sure if you are using a text editor with a curses only wicd

/etc/network/interfaces can be hand editted otherwise have a peek at

jdkaye 11-07-2013 02:37 AM

No worries. In any event I'm used to setting up wifi connections so as long as the drivers are working I shouldn't have any problem. In fact I like to see the various AP's around me.

As I said, I'll report back when the dongle arrives and confirm that I can get it working.

jdkaye 11-14-2013 11:26 AM

Dongle arrived but how do I install the driver?
So the dongle works with the ZyXEL driver zd1211rw. But I can't find the RTL8192SU driver. I have installed the firmware-realtek package but lsmod shows no sign of any module being installed. Since zd1211rw doesn't support 802.11n there's no point in changing from my old ZyXEL dongle. Can you tell me what the driver file is and how I install it. I seem to missing a step here after I install the firmware-realtek package.

jdkaye 11-18-2013 02:53 AM

Success! ...sort of but weird
Ok, now the dongle works and I get speeds up to 37+ Mbs whereas I could only manage around 21Mbs on my old 802.11b/g dongle. I did need to manually insmod the r8172u module. But here's the weird thing: when I boot up with the RT dongle plugged in there is no sign of life; no blue light flashes. No reaction at all. To get the wifi working I have to boot up with the old dongle. Once the system is running I then unplug the old dongle and put in the new dongle. The new dongle then responds and performs normally. The substitution changes my ip address (within the local network) and my hostname gets lost and is replaced by "unknown-<mac address>" No amount of fiddling with the hosts, hostname or dhclient files change this behaviour. Any suggestions about these two anomalies would be most welcome.

All times are GMT -5. The time now is 11:58 PM.